By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,376 Members | 1,599 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,376 IT Pros & Developers. It's quick & easy.

Fwd: problem CMFOODocument/python2.1/libxml2mod

P: n/a


---------- Forwarded Message ----------

Subject: problem CMFOODocument
Date: Tuesday 21 October 2003 11:18
From: johan <jo*****@easynet.be>
To: zo**@zope.org

Hi,

I have the following problem : I try to install CMFOODocument into Products
directory. As far as I know I intsalled libxml2, libxslt and its python
bindings, according to http://www.icoya.org/download_area/zope/libxml2-zope
When I rebooted zope, I receive the following error , apparently problem with
lixml2mod.so. Anybody has an idea ?

Greetings,
Johan
Traceback (most recent call last):
File "/usr/local/src/zope/lib/python/OFS/Application.py", line 541, in
import_product
product=__import__(pname, global_dict, global_dict, silly)
File "/usr/local/src/zope/lib/python/Products/CMFOODocument/__init__.py",
line 19, in ?
import OODocument
File "/usr/local/src/zope/lib/python/Products/CMFOODocument/OODocument.py",
line 46, in ?
import libxml2
File "/usr/lib/python2.1/site-packages/libxml2.py", line 1, in ?
import libxml2mod
ImportError: /usr/lib/python2.1/site-packages/libxml2mod.so: undefined
symbol: xmlValidateNamesValue


Zope Version
(Zope 2.6.1 (source release, python 2.1, linux2), python 2.1.3, linux2)
Python Version
2.1.3 (#1, Sep 7 2002, 15:29:56) [GCC 2.95.4 20011002 (Debian prerelease)]
System Platform linux2

-------------------------------------------------------
Jul 18 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.