By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,225 Members | 2,187 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,225 IT Pros & Developers. It's quick & easy.

Python 2.3 IDLE doesn't show on Win2000

P: n/a
Trying to start Python IDLE through Start>Programs>Python 2.3> IDLE doesn't
work

From DOS ... I get this ....

C:\>python C:\Python23\Lib\idlelib\idle.py
Traceback (most recent call last):
File "C:\Python23\Lib\idlelib\idle.py", line 23, in ?
idlelib.PyShell.main()
File "C:\Python23\lib\idlelib\PyShell.py", line 1264, in main
root = Tk(className="Idle")
File "C:\Python23\lib\lib-tk\Tkinter.py", line 1564, in __init__
self.tk = _tkinter.create(screenName, baseName, className)
_tkinter.TclError: Can't find a usable init.tcl in the following directories
{C:\ptc\dataserver\intralink\tools\lib\tcl} {C:\ptc\dataserver\intralink
ls\lib\tcl} C:/ptc/dataserver/intralink/tools/lib/tcl8.4 c:/python23/lib/tcl
c:/lib/tcl8.4 c:/library

C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl: version conflict for pac
"Tcl": have 8.4, need 8.2
version conflict for package "Tcl": have 8.4, need 8.2
while executing
"package require -exact Tcl 8.2"
(file "C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl" line 19)
invoked from within
"source C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl"
("uplevel" body line 1)
invoked from within
"uplevel #0[list source $tclfile]"
C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl: version conflict for pac
"Tcl": have 8.4, need 8.2
version conflict for package "Tcl": have 8.4, need 8.2
while executing
"package require -exact Tcl 8.2"
(file "C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl" line 19)
invoked from within
"source C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl"
("uplevel" body line 1)
invoked from within
"uplevel #0[list source $tclfile]"
This probably means that Tcl wasn't installed properly.
Jul 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I have this same problem at work, but at home it works fine. Python 2.2's
IDLE works fine on both machines. It's only 2.3 at work. I saw a web page
that says that IDLE uses 127.0.0.1 or something now for new processes and
that interferes with some firewalls, but the firewall has to be on the
machine? I don't remember the details -- it's on the Python website
somewhere under "Known Bugs". Oh well, I dunno what to do about it. I'm
just sticking with 2.2 at worknow.

Miine just doesn't load. You double click, and then you see the cursor turn
to the hourglass briefly, and then nothing. IDLE doesn't start, no matter
how many times you try to launch it.

Andy

"Vin Jovanovic" <fr*******@comcast.com> wrote in message
news:MM********************@comcast.com...
Trying to start Python IDLE through Start>Programs>Python 2.3> IDLE doesn't work

From DOS ... I get this ....

C:\>python C:\Python23\Lib\idlelib\idle.py
Traceback (most recent call last):
File "C:\Python23\Lib\idlelib\idle.py", line 23, in ?
idlelib.PyShell.main()
File "C:\Python23\lib\idlelib\PyShell.py", line 1264, in main
root = Tk(className="Idle")
File "C:\Python23\lib\lib-tk\Tkinter.py", line 1564, in __init__
self.tk = _tkinter.create(screenName, baseName, className)
_tkinter.TclError: Can't find a usable init.tcl in the following directories {C:\ptc\dataserver\intralink\tools\lib\tcl} {C:\ptc\dataserver\intralink ls\lib\tcl} C:/ptc/dataserver/intralink/tools/lib/tcl8.4 c:/python23/lib/tcl c:/lib/tcl8.4 c:/library

C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl: version conflict for pac "Tcl": have 8.4, need 8.2
version conflict for package "Tcl": have 8.4, need 8.2
while executing
"package require -exact Tcl 8.2"
(file "C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl" line 19)
invoked from within
"source C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl"
("uplevel" body line 1)
invoked from within
"uplevel #0[list source $tclfile]"
C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl: version conflict for pac "Tcl": have 8.4, need 8.2
version conflict for package "Tcl": have 8.4, need 8.2
while executing
"package require -exact Tcl 8.2"
(file "C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl" line 19)
invoked from within
"source C:/ptc/dataserver/intralink/tools/lib/tcl/init.tcl"
("uplevel" body line 1)
invoked from within
"uplevel #0[list source $tclfile]"
This probably means that Tcl wasn't installed properly.

Jul 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.