By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,404 Members | 1,074 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,404 IT Pros & Developers. It's quick & easy.

pyzeroconf on linux...

P: n/a
Hey, has anyone out there tried pyzeroconf on Linux? I'm using
Andrew's code from http://www.amk.ca/python/zeroconf to publish and
discover services. The code works under Mac. But it doesn't under
linux (FC4).

I should clarify that, it appears that the publish code doesn't work
under linux. The discovery code will discover stuff (on linux) that I
publish on the Mac. I've fired up ethereal and it doesn't appear that
much is happening in the way of UDP on port 5353 (on linux).

Does anyone have any hints or suggestions?

thanks

matt

Nov 2 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Another (easier) example of it failing, is to just run "python
Zeroconf.py":
1. Testing registration of a service...
Registering service...
Registration done.
2. Testing query of service information...
Getting ZOE service: None
Query done.
3. Testing query of own service...
Getting self: None
Query done.
4. Testing unregister of service information...
Unregister done.

On the Mac section 3. actually returns something other than "None" (ie
service[My Service Name._http._tcp.local.,127.0.0.1:1234, a=test value
ver ...] ).

Nov 2 '05 #2

P: n/a
I think I've figured it out. It appears to be a misconfiguration on my
part. In my /etc/hosts file I had the loopback address pointing to my
machine name. I made 127.0.0.1 only point to localhost and I can now
publish services!

Nov 2 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.