By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,627 Members | 1,211 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,627 IT Pros & Developers. It's quick & easy.

Run VPython on FC3

P: n/a
Hi everybody,

I am trying to run VPython on FC3. The installation was fine. But when I
"import visual", an error occurs:

"""
import visual Traceback (most recent call last):
File "<stdin>", line 1, in ?
File "/usr/lib/python2.3/site-packages/visual/__init__.py", line 15, in ?
import array_backend
File "/usr/lib/python2.3/site-packages/visual/array_backend.py", line
1, in ?
import cvisual
ImportError: libgtkgl.so.4: cannot open shared object file: No such file
or directory

"""

It seems Python cannot open/find the file "libgtkgl.so.4", but it
definitely lies in the lib directory:

/usr/local/lib/libgtkgl.so.4.0.0
/usr/local/lib/libgtkgl.so.4

Does anybody know a solution for this problem?

Thanks very much,

York
Sep 16 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
In the darkest hour on Fri, 16 Sep 2005 10:44:34 -0700,
York <yo*******@gmail.com> screamed:
It seems Python cannot open/find the file "libgtkgl.so.4", but it
definitely lies in the lib directory:

/usr/local/lib/libgtkgl.so.4.0.0
/usr/local/lib/libgtkgl.so.4

Does anybody know a solution for this problem?


You need libgtk-(open)gl package (i don't know the exact name in FC).

--
[ Artur M. Piwko : Pipen : AMP29-RIPE : RLU:100918 : From == Trap! : SIG:216B ]
[ 21:56:44 user up 10736 days, 9:51, 1 user, load average: 0.06, 0.06, 0.06 ]

Machine independent code isn't.
Sep 16 '05 #2

P: n/a
Artur M. Piwko wrote:
In the darkest hour on Fri, 16 Sep 2005 10:44:34 -0700,
York <yo*******@gmail.com> screamed:
It seems Python cannot open/find the file "libgtkgl.so.4", but it
definitely lies in the lib directory:

/usr/local/lib/libgtkgl.so.4.0.0
/usr/local/lib/libgtkgl.so.4

Does anybody know a solution for this problem?

You need libgtk-(open)gl package (i don't know the exact name in FC).


Actually the gtkgl was installed, I can find it at /usr/local/lib:
/usr/local/lib/libgtkgl.so.4.0.0
/usr/local/lib/libgtkgl.so.4
- York
Sep 16 '05 #3

P: n/a
In the darkest hour on Fri, 16 Sep 2005 15:45:33 -0700,
York <yo*******@gmail.com> screamed:
/usr/local/lib/libgtkgl.so.4.0.0
/usr/local/lib/libgtkgl.so.4

Does anybody know a solution for this problem?


You need libgtk-(open)gl package (i don't know the exact name in FC).

Actually the gtkgl was installed, I can find it at /usr/local/lib:
/usr/local/lib/libgtkgl.so.4.0.0
/usr/local/lib/libgtkgl.so.4


Check for presence of /usr/local/lib in /etc/ld.so.conf
Append it if necessary. Don't forget to run ldconfig afterwards.

--
[ Artur M. Piwko : Pipen : AMP29-RIPE : RLU:100918 : From == Trap! : SIG:228B ]
[ 21:38:09 user up 10743 days, 9:33, 1 user, load average: 0.06, 0.06, 0.06 ]

I considered atheism but there weren't enough holidays.
Sep 23 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.