473,725 Members | 2,385 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Linking problems under irix6 with embedded Python2.4

I have a problem with linking my CPP Code under a irix6 machine (sgi,
UNIX). In my CPP code I use some Functions which are written in
Python. So its a kind of CPP wrapper for my Python functions In my
Python Code I use threads to communicate over the network and stuff
like this. Compilation and linking are working very well under Windows
and Linux with the same code. Under the sgi, UNIX machine some errors
occur and I don't no why. Following version are used:
Python2.4
gcc version 3.0.4

For linking I'am using following statement:
g++ -v -lm -lpthread -lsocket -lnsl -ldl -DNDEBUG -g -O3 -Wall
-fno-strict-aliasing -fPIC -Xlinker
-I/work/efs/rohrache/python24/Python2.4/local/lib/python2.4/lib-dynload
DynArray.o Interface.o sim_calc.o -o simcalc
/work/efs/rohrache/python24/Python-2.4/libpython2.4.a

The linking options, I take from the makefile which Python produces
during the installation process. Following output occur.

=> ...
Reading specs from /usr/freeware/lib/gcc-lib/mips-sgi-irix6.5/3.0.4/specs
Configured with: ../configure --prefix=/usr/freeware
--enable-version-spec
ific-runtime-libs --disable-shared --enable-threads --enable-haifa
Thread model: single
gcc version 3.0.4
/usr/freeware/lib/gcc-lib/mips-sgi-irix6.5/3.0.4/collect2
-call_shared -n
o_unresolved -init __do_global_cto rs -fini __do_global_dto rs
-_SYSTYPE_SVR
4 -woff 131 -n32 -o simcalc /usr/lib32/mips3/crt1.o
/usr/freeware/lib/gcc-
lib/mips-sgi-irix6.5/3.0.4/crtbegin.o
-L/usr/freeware/lib/gcc-lib/mips-sgi
-irix6.5/3.0.4 -L/usr/bin
-L/usr/freeware/lib/gcc-lib/mips-sgi-irix6.5/3.0
..4/../../.. -lpthread -lsocket -lnsl -ldl
-I/work/efs/rohrache/python24/Py
thon2.4/local/lib/python2.4/lib-dynload DynArray.o Interface.o
sim_calc.o
/work/efs/rohrache/python24/Python-2.4/libpython2.4.a -lstdc++ -lm
-dont_w
arn_unused -lgcc -warn_unused -L/usr/lib32/mips3 -L/usr/lib32
-dont_warn_u
nused -lc -warn_unused -dont_warn_unuse d -lgcc -warn_unused
/usr/freeware/
lib/gcc-lib/mips-sgi-irix6.5/3.0.4/crtend.o /usr/lib32/mips3/crtn.o
(null): WARNING 1 : Unknown option:
I/work/efs/rohrache/python24/Python2.
4/local/lib/python2.4/lib-dynload (ignored).
ld32: WARNING 84 : /usr/lib32/libpthread.so is not used for resolving
any
symbol.
ld32: WARNING 84 : /usr/lib32/libsocket.so is not used for resolving
any s
ymbol.
ld32: WARNING 84 : /usr/lib32/libnsl.so is not used for resolving any
symb
ol.
ld32: WARNING 84 : /usr/lib32/libdl.so is not used for resolving any
symbo
l.
ld32: ERROR 33 : Unresolved text symbol "pthread_detach " -- 1st
referenc
ed by /work/efs/rohrache/python24/Python-2.4/libpython2.4.a( thread.o).
Use linker option -v to see when and which objects, archives
and d
sos are loaded.
ld32: INFO 152: Output file removed because of error.
collect2: ld returned 2 exit status

The warnings are no problem to eliminate, but the error message is
very strange.
I don't know how i can handle this problem. I tried alot of additional
link options but I can find no realy solution. Are there some ideas.

thank's alot.
Wolfgang
Jul 18 '05 #1
0 1718

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

2
3509
by: Rick Olson | last post by:
I'm trying to add a Tkinter interface to an existing C program with embedded python, but seem to have trouble importing Tkinter (or accessing it). I tried a simple program that would run the script "hello.py" This is hello.py: from Tkinter import * mainWindow=Tk() label=Label(mainWindow, text="Hello") label.grid(row=0,column=0)
0
1242
by: Jeffrey Holle | last post by:
I am working on a Linux system using gcc v3.3 and python v2.3.2 I have a problem linking a cpp program to a shared library that uses the Python C API. With just referencing this shared library, I get unresolved references like: PySequence_DelSlice PyNumber_InPlaceXor PyInt_FromLong _PyObject_New This is just a sample, there are actually 130 of similarly named functions.
1
2589
by: Jeff Hagelberg | last post by:
I'm trying to create a python module which can be used by a python interpreter embedded inside a fortran program I have. To do this, I first created python wrappers for all the functions in my fortran program using f2py. I then start an embedded python interpreter in c code which I link against the fortran program. I invoke the fortran program with a filename containing python code. This file is passed to the c code which passes it on...
0
2020
by: Richard Taylor | last post by:
User-Agent: OSXnews 2.07 Xref: number1.nntp.dca.giganews.com comp.lang.python:437315 Hi I am trying to use py2app (http://undefined.org/python/) to package a gnome-python application called gramps (http://www.gramps-project.org) for MAC OS X.
0
886
by: Xiao Jianfeng | last post by:
Hello, I am trying to install python2.4.2 on a SGI origin3200 machine running IRIX6.5. The native c compiler was used to compile python. "./configure --prefix=/my/path/to/install" runs ok, then, "smake OPT= " runs ok but "smake test" gets errors, here is the output: ------------------------------------------------
0
1134
by: Xiao Jianfeng | last post by:
Hello, I am trying to install python2.4.2 on IRIX6.5, but test_fpformat and test_locale failed when I ran "smake test". The following is the detailed error message: -------------------------------------------------------------------------------------------------------- prompt:\> ./python ./Lib/test/test_fpformat.py test_basic_cases (__main__.FpformatTest) ... ok
1
3183
by: jmalone | last post by:
I have a python script that I need to freeze on AIX 5.1 (customer has AIX and does not want to install Python). The python script is pretty simple (the only things it imports are sys and socket). The README file in the Tools/freeze directory of the Python-2.4.4 distribution says the following (and many other things): Previous versions of Freeze used a pretty simple-minded algorithm to
0
1032
by: Lane Brooks | last post by:
When I run a particular python script from an embedded interpreter, I get the following ImportError: File "di.py", line 14, in load from xml.dom.ext.reader import Sax2 File "/usr/lib64/python2.4/site-packages/_xmlplus/dom/ext/reader/__init__.py", line 14, in ? import string, urllib2, urlparse, cStringIO, os File "/usr/lib64/python2.4/urllib2.py", line 90, in ?
4
2484
by: Markus Dahlbokum | last post by:
Hello, I'm trying to link python statically with qt and pyqt. I've tried this in several ways but never succeeded. At the moment the final make runs without errors but I get import errors when accessing pyqt. How can I solve this problem? Markus # installing zipimport hook
0
8874
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main usage, and What is the difference between ONU and Router. Let’s take a closer look ! Part I. Meaning of...
0
8748
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
9393
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
0
9092
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
1
6695
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes instead of User Defined Types (UDT). For example, to manage the data in unbound forms. Adolph will...
0
6000
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
0
4775
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
2
2622
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.
3
2151
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.