473,546 Members | 2,798 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

/usr/lib/python2.4/posixfile.py error

Hi,

Wonder if anyone can help me?

I am trying to run a perl script but I keep getting this error:

/usr/lib/python2.4/posixfile.py:59 : DeprecationWarn ing: The posixfile
module is obsolete and will disappear in the future
DeprecationWarn ing)

I am running Ubuntu Hoary 5.10. I'll try the same script on my gentoo
box at work tommorrow, but really would like to run this script asap.

Any ideas on why it's failing on that python module?

Any ideas greatfully received,

Chris
Nov 4 '05 #1
2 1438
Chris wrote:
Wonder if anyone can help me?
I very much doubt that, with as little information you gave us.
I am trying to run a perl script but I keep getting this error:

/usr/lib/python2.4/posixfile.py:59 : DeprecationWarn ing: The posixfile
module is obsolete and will disappear in the future
DeprecationWarn ing)
It's very strange that you get a Python error when running a Perl
script.
Any ideas on why it's failing on that python module?


It's not failing. It's a warning, not an error. The warning is
that the Python code you are running uses the posixfile module,
and it should be rewritten to stop doing so, as the posixfile
module will go away eventually.

Regards,
Martin
Nov 4 '05 #2
In article <43************ ***********@new s.freenet.de>,
ma****@v.loewis .de says...
Chris wrote:
Wonder if anyone can help me?


I very much doubt that, with as little information you gave us.
I am trying to run a perl script but I keep getting this error:

/usr/lib/python2.4/posixfile.py:59 : DeprecationWarn ing: The posixfile
module is obsolete and will disappear in the future
DeprecationWarn ing)


It's very strange that you get a Python error when running a Perl
script.


So I thought ;)

However, it's a perl script that invokes python.

http://search.cpan.org/~rprice/Nokia...ia/File/NFB.pm
Any ideas on why it's failing on that python module?


It's not failing. It's a warning, not an error. The warning is
that the Python code you are running uses the posixfile module,
and it should be rewritten to stop doing so, as the posixfile
module will go away eventually.


Ok, many thanks. I got it working in the end, appears that the nfb.py
script requires the file it is processing to be in the same directory.
Which is quite annoying, but at least I know how to sort it now.

Many thanks for your quick reply and apologies for my late one :(

Cheers,
Chris
Nov 5 '05 #3

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

5
2681
by: Mike S. | last post by:
Hello, Has anyone had success compiling the informixdb-1.3 module under python 2.2? It seems the absense of makefile.pre.in in python 2.2 causes the break under py2.2. Is there an easy way around this. I've heard rumors of a manual method, but have been unable to track down details. Any help is very much appreciated. Thanks in...
2
4569
by: Jakub Moscicki | last post by:
Hello, A small problem: I get a signal during a system call (from xmlrpclib -> httplib) and an exception "IOError: Interrupted system call" is raised (this is system dependant, on other machine it does not raise this exception). I have my own signal handler so I want to simply ignore this exception if it occures. But for a reason...
3
3072
by: Adil Hasan | last post by:
Hello, I'm having problems trying to use ZSI to connect to a https url. I give the command and I get prompted for my X509 cert pass-phrase, but the program dies with an openssl error. Here's my code: from ZSI import * u='' n='https://shahzad.fnal.gov/edg-voms-admin/uscms/services/VOMSAdmin'
1
1264
by: chetan hs | last post by:
Hi, I have installed Red Hat Linux 9, and tried to install python2.3 on python2.2 but there was a library installation error, while doing "make install". I wanted to access BerkelyDB4.2 from python but it was not possible. Please can you help me rectify that error. BerkeleyDB4.2 is installed without any errors. regards, chetan
0
1708
by: Wolfgang | last post by:
I have a problem with linking my CPP Code under a irix6 machine (sgi, UNIX). In my CPP code I use some Functions which are written in Python. So its a kind of CPP wrapper for my Python functions In my Python Code I use threads to communicate over the network and stuff like this. Compilation and linking are working very well under Windows and...
2
1644
by: venkatbo | last post by:
Hi all, I have python2.4 running on ppc-linux 2.6.17. I'm attempting to get a TurboGears 0.9a9 (using CherryPy 2.2.1) based app running on it. During the TG-app startup sequence, it reaches the point where it imports cherrypy, which eventually causes py2.4's system file, compiler/transformer.py, to import a module by name, symbol....
15
5536
by: Christopher Taylor | last post by:
RHEL comes with Python2.3 installed. A program I need to install requires Python2.4 So I got Python2.4 from source and compiled it up. I configured it with --prefix=/usr --exec-prefix=/usr and --enable-unicode=ucs4 . I then make'd it and then make altinstall so that it didn't overwrite the /usr/bin/Python link to /usr/bin/Python2.3 . ...
6
22463
by: samn | last post by:
i compiled and installed the release version of python 2.5 for linux to a directory accessible to 2 computers, configured with --prefix=/usr/arch (which is accessible to both machines). the installation went fine and when i run python on one machine i can do from hashlib import * without a problem. on the other machine i get the following...
2
1953
by: Pradnyesh Sawant | last post by:
Hello, I have a code snippet which does 'import xmltramp' to parse an xml file received over the network. Also, I have 2 instances of python, namely python2.4 and python2.5 on my box. The confusing thing is that the code works fine with python2.4, but gives the error: ImportError: No module named xmltramp when used with python2.5. Why is...
0
7502
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main...
0
7692
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. ...
0
7946
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that...
1
7457
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For...
0
6026
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then...
0
3491
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in...
0
3470
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
1
1045
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.
0
744
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.