By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,251 Members | 2,727 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,251 IT Pros & Developers. It's quick & easy.

PostgreSQL installation error “FATAL: invalid byte sequence for encoding ”UTF8“: 0xeb

P: 1
One of my clients is facing PostgreSQL installation failures through postgresql installer binary "postgresql-9.6.6-1-linux-x64.run" on CentOS 7.6 server. The error in /tmp/install-postgresql.log is given below....

performing post-bootstrap initialization ... Failed to initialize the database cluster with initdb with the error "invalid byte sequence for encoding "UTF8"

Script stderr:
FATAL: invalid byte sequence for encoding "UTF8": 0xeb 0x2f 0xdb
child process exited with exit code 1
initdb: removing contents of data directory "/home/postgres/9.6/data"

Error running /home/postgres/9.6/installer/server/initcluster.sh "postgres" "postgres" "/home/postgres/9.6" "/home/postgres/9.6/data" 5432 DEFAULT: FATAL: invalid byte sequence for encoding "UTF8": 0xeb 0x2f 0xdb
child process exited with exit code 1
initdb: removing contents of data directory "/home/postgres/9.6/data"
Problem running post-install step. Installation may not complete correctly
The database cluster initialisation failed.
Problem running post-install step. Installation may not complete correctly
The database cluster initialisation failed.

The postgresql installer is run on unattended mode with all of the input arguments are passed to command line. Here is an example:

./postgresql-9.6.6-1-linux-x64.run --installer-language en --serviceaccount postgres --servicename postgresqld --datadir "/home/postgres/" --prefix "/home/postgres" --superpassword **** --serverport 5432 --debuglevel 4 --debugtrace ./postgresql-debug.log --mode unattended
The client's locale is 'en_US.utf8' which is same as the default encoding format of PostgreSQL.

This is happening only for this customer. For other customer's installation is happening without any issues.
Can someone please help me on this....
2 Weeks Ago #1
Share this question for a faster answer!
Share on Google+

Post your reply

Sign in to post your reply or Sign up for a free account.