By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
431,745 Members | 1,897 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 431,745 IT Pros & Developers. It's quick & easy.

Server doesn't listen

P: 1
I have a local copnnection with Postgres setup for development on my PC. This has been working for months with the default configuration.
I recently set up to access a server and got this error when I tried to connect.
I dropped the server and still got the message - I can't now connect to the server at all, and still get the listener message
My postgresql.conf was set to * for listen addresses. I tried setting my IP address and that of the server but this made no difference.
I am running PostgreSQL 8.4 on a windows network.

the full error message is

Server doesn't listen
The server doesn't accept connections: the connection library reports
could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "127.0.0.1" and accepting TCP/IP connections on port 5432?
If you encounter this message, please check if the server you're trying to contact is actually running PostgreSQL on the given port. Test if you have network connectivity from your client to the server host using ping or equivalent tools. Is your network / VPN / SSH tunnel / firewall configured correctly?
For security reasons, PostgreSQL does not listen on all available IP addresses on the server machine initially. In order to access the server over the network, you need to enable listening on the address first.
For PostgreSQL servers starting with version 8.0, this is controlled using the "listen_addresses" parameter in the postgresql.conf file. Here, you can enter a list of IP addresses the server should listen on, or simply use '*' to listen on all available IP addresses. For earlier servers (Version 7.3 or 7.4), you'll need to set the "tcpip_socket" parameter to 'true'.
You can use the postgresql.conf editor that is built into pgAdmin III to edit the postgresql.conf configuration file. After changing this file, you need to restart the server process to make the setting effective.
If you double-checked your configuration but still get this error message, it's still unlikely that you encounter a fatal PostgreSQL misbehaviour. You probably have some low level network connectivity problems (e.g. firewall configuration). Please check this thoroughly before reporting a bug to the PostgreSQL community.
Jun 17 '10 #1
Share this Question
Share on Google+
1 Reply


Expert 100+
P: 700
What system do you use?
What does the command
Expand|Select|Wrap|Line Numbers
  1. pg_ctl status
  2.  
show?
How did you try to connect to server, what client do you use, what command to connect?
Does the netstat command show that postgres is listening on port 5432?
Jun 28 '10 #2

Post your reply

Sign in to post your reply or Sign up for a free account.