By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,952 Members | 1,384 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,952 IT Pros & Developers. It's quick & easy.

PANIC: read of clog file 3165, offset 0 failed: Success

P: 17
Hi

Please assist, I got an error from a server that's running PostgreSQL 7.3.4 on CentOS5



Problem started with the database not starting up showing the following error:

LOG: database system was interrupted at 2010-04-19 07:55:47 SAST
LOG: ReadRecord: unexpected pageaddr 44/E43D8000 in log file 68, segment 239, offset 4030464
LOG: invalid primary checkpoint record
LOG: ReadRecord: unexpected pageaddr 44/E4344000 in log file 68, segment 239, offset 3424256
LOG: invalid secondary checkpoint record
PANIC: unable to locate a valid checkpoint record
LOG: startup process (pid 9129) was terminated by signal 6
LOG: aborting startup due to startup process failure



First action:

I reset the x logs: by typing pg_resetxlog f /data/postgres7.3.4/data/

Then the database started up fine


2nd action I tried to vacuum the database, then the following error came up:

PANIC: open of /data/postgres7.3.4/data/pg_clog/0C5D failed: No such file or directory


3rd action I created this file 0C5D and then tried to vacuum the database again, the following new error appeared:

PANIC: read of clog file 3165, offset 0 failed: Success
server closed the connection unexpectedly
This probably means the server terminated abnormally
before or while processing the request.
The connection to the server was lost. Attempting reset: Failed.
Apr 19 '10 #1
Share this question for a faster answer!
Share on Google+

Post your reply

Sign in to post your reply or Sign up for a free account.