By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,952 Members | 1,686 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,952 IT Pros & Developers. It's quick & easy.

OpenOffice.org, PostgreSQL and Unicode

P: 3
I have a PostgreSQL database encode in UTF-8. I try to do a mail merge from OOwriter. This seems to work except for non western characters. E.g. when I access the database from pgAdmin, a GUI client I can see all UTF-8 encoded characters. When I cut a text from the GUI and paste this text in OOwriter everything works well. The same text through a mail merge only shows question marks. An example:
---------------
เมืองไทย

TH
Thailand
????????
---------------
The first line is cut from pgAdmin and pasted into OOwriter. The other lines the mail merge. The ?????? should be เมืองไทย .

First I thought I could correct this by setting:

Database->open and existing database file->right click to go to "database properties"->set Data conversion character set to "Unicode (UTF-->save)

but that doesn't help. Then on this site I read the question and answer on:
http://bytes.com/topic/postgresql/answers/857378-client-encoding-postgresql so I thought that might have somethig to do with it. But I can't find something like a client_encoding setting in OpenOffice Base.

Any help would be really appreciated.
Oct 11 '09 #1
Share this Question
Share on Google+
2 Replies


P: 48
it's up of the driver, try another : postgresql sdbc is a native one for open office, odbc, jdbc...

The odbc package has two drivers : ANSI and Unicode

I tried odbc and sdbc and both workerd for me with an UTF-8 db
Oct 16 '09 #2

P: 3
Unfortunately these drivers are Windows/Linux only. I need OS X. Sure I can build them from source but I will only do that as a last resort. A few days ago I purchased a driver from Actualtechologies for OS X and that driver doesn't work with UNICODE UTF-8.

Thanks for the response anyway.
Oct 16 '09 #3

Post your reply

Sign in to post your reply or Sign up for a free account.