By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,949 Members | 890 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,949 IT Pros & Developers. It's quick & easy.

CREATE LANGUAGE cannot load library

P: 1
I am rather new to PostgreSQL and so have probably done something stupid (or not done something). I am running PostgreSQL 8.2.5 on Windows Vista. When I use 'create language' to add pl/perl to a database, I get the following error:

ERROR: could not load library "C:/Program Files/PostgreSQL/8.2/lib/plperl.dll":
The specified module could not be found.


However if I look in the directory that it indicates, plperl.dll is actually there, and I do have the full Perl package installed on my system. I notice that it has the slashes ('/') facing the wrong direction. I have looked for a setting in this regard but can't find one. Is this just the error message or is that actually where it is looking, and how can I fix it?

Any help would be appreciated.
Oct 18 '07 #1
Share this question for a faster answer!
Share on Google+

Post your reply

Sign in to post your reply or Sign up for a free account.