By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,587 Members | 1,020 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,587 IT Pros & Developers. It's quick & easy.

Error:: 'more' is not recognized as an internal or external command

P: 40
Hai,
can anyone tel me what dose this error mean.
'more' is not recognized as an internal or external command,
operable program or batch file.
Jul 31 '07 #1
Share this Question
Share on Google+
8 Replies


Expert 100+
P: 534
Where and how are you trying to execute the "more" command?
You don't give enough details to answer the question you posted.
Aug 1 '07 #2

P: 40
Hai,
find the below...

C:\Program Files\PostgreSQL\8.2\bin>psql testDB xyz
Password for user xyz:
Welcome to psql 8.2.4, the PostgreSQL interactive terminal.

Type: \copyright for distribution terms
\h for help with SQL commands
\? for help with psql commands
\g or terminate with semicolon to execute query
\q to quit

Warning: Console code page (437) differs from Windows code page (1252)
8-bit characters may not work correctly. See psql reference
page "Notes for Windows users" for details.

testDB=> select * from test;
'more' is not recognized as an internal or external command,
operable program or batch file.
testDB=>

I unable to resolve this,Im very new to PostgreSQL.
Kindly revert back.

Thank you
Aug 2 '07 #3

P: 40
Hai,

one more thing is,i have instaled PostgreSQl directly on Windows.From postgresql.com ,from FTP mirrors.
But i have doubt is the installation some where wrong,as i have come across the forums that PostgreSQL has to be installed through Cygwin.Im confused.
Right now im able to create DB,tables and import data through PGAdmin.
am I wrong anywere,im confused.
Aug 2 '07 #4

Expert 100+
P: 534
Let's try to gather some information:

Open the DOS window and at the prompt type this command:
more abc
Hit the Enter key. What happens?

What version of Windows you are currently using?
Was it a fresh install, or did you upgrade from some previous version?
Aug 2 '07 #5

P: 40
Let's try to gather some information:

Open the DOS window and at the prompt type this command:
more abc
Hit the Enter key. What happens?

What version of Windows you are currently using?
Was it a fresh install, or did you upgrade from some previous version?
Yup,this is wht i get..
Im using Windows XP

C:\Program Files\PostgreSQL\8.2\bin>more
'more' is not recognized as an internal or external command,
operable program or batch file.

C:\Program Files\PostgreSQL\8.2\bin>psql testDB sindhu
Password for user sindhu:
Welcome to psql 8.2.4, the PostgreSQL interactive terminal.

Type: \copyright for distribution terms
\h for help with SQL commands
\? for help with psql commands
\g or terminate with semicolon to execute query
\q to quit

Warning: Console code page (437) differs from Windows code page (1252)
8-bit characters may not work correctly. See psql reference
page "Notes for Windows users" for details.

testDB=> \h;
'more' is not recognized as an internal or external command,
operable program or batch file.
Aug 6 '07 #6

Expert 100+
P: 534
Typically you should have the more command (file more.com) in your Windows\system32 directory.
If you don't have it - install it. If it's there make sure that path C:\WINDOWS\system32 (or whatever the path is in your computer) is in the PATH variable.
You can take a quick look at your path settings using the set command at the DOS prompt.

Expand|Select|Wrap|Line Numbers
  1. C:\>set path
  2. Path=C:\WINDOWS\system32;C:\WINDOWS;C:\Program Files\SecureCRT3.0;C:\Program Files\PostgreSQL\8.2\bin
  3.  
Aug 6 '07 #7

P: 40
Typically you should have the more command (file more.com) in your Windows\system32 directory.
If you don't have it - install it. If it's there make sure that path C:\WINDOWS\system32 (or whatever the path is in your computer) is in the PATH variable.
You can take a quick look at your path settings using the set command at the DOS prompt.

Expand|Select|Wrap|Line Numbers
  1. C:\>set path
  2. Path=C:\WINDOWS\system32;C:\WINDOWS;C:\Program Files\SecureCRT3.0;C:\Program Files\PostgreSQL\8.2\bin
  3.  

Thanks a lotttt michaelb..
Its working fine..

Kindly look into my other error too..
org.postgresql.util.PSQLException: ERROR: relation "gistl_new_request" does not exist
Even though i have the table by name "gistl_new_request",im getting this error.
Plz michaelb look into it..

Thank you once again..
Aug 7 '07 #8

Expert 100+
P: 534
You're welcome.

The other problem you mentioned is being discussed here
Aug 7 '07 #9

Post your reply

Sign in to post your reply or Sign up for a free account.