By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
431,661 Members | 781 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 431,661 IT Pros & Developers. It's quick & easy.

Pgsql 8.4 on Vista starts and stops automatically.

P: 2
I am having the same problem as experienced in http://www.thescripts.com/forum/thread422776.html


Here's a short excerpt of that discussion:
========
> But after a few days, when I tried to continue with my tests.
> I cannot start the postgresql service. I always get this
> message windown when I try to start the service:
>
> "The postgresql service on the local computer started and
> stopped. some services stop automatically if they have no
> work to do, for example the performance logs and alerts services"
>
> The service starts and stops automatically and I cannot to
> work with pgsql.
>
> PS: I have translated (get from internet) the text message
> window because I have my system in spanish language.[/color]

This looks a lot like the postmaster.pid issue. Look in your DATA
directory, and remove that file if it exists.

If not, then it's a different issue. In this case, edit the
postgresql.conf file and set log_destination to include eventlog, then
look at eventlog output. (This is an issue with the installer that will
be fixed in the next beta release)
===========

This user was successful in solving the problem by deleteing the postmaster.pid file. I did a search on my Vista PC, and that file does not exist.

I'm guessing that this is an issue with Vista and PGsql wanting to write to the Program Files filder.

Any ideas?

Thanks,
Rocky
Jul 10 '07 #1
Share this Question
Share on Google+
3 Replies


P: 2
Of course, that's 8.2.4... :-)
Jul 10 '07 #2

Expert 100+
P: 534
Did you see any relevant messages in the postgresql log or windows event log?
Jul 14 '07 #3

P: 1
Windows Postgres service starts and stops.

I was getting a similar error on a Windows 2003 Server and solved it (I think!) at least I was able to get the service to start. What is the user that the service logon is connecting as? mine was set to postgres (I used the defaults) but I know that my postgres logon doesn't have full admin rights, so I changed it to Local System account and it let me start the service.

I will check and see if everything else seems to be in order.
Jun 26 '08 #4

Post your reply

Sign in to post your reply or Sign up for a free account.