By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
464,303 Members | 1,271 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 464,303 IT Pros & Developers. It's quick & easy.

too many clients already?????

P: n/a
Dan
I have a server under very light load -- just me doing some work in php.
I am getting this error often and don't know why:

postgresql max connections Unable to connect to PostgreSQL server:
FATAL: Sorry, too many clients already

my postgresql.conf had:

max_connections = 8
shared_buffers = 16

I changed those to 32 and 64 and it is working so far. But I have a
bunch of postgresses running now with all of them doing almost nothing:

postgres 11747 0.0 0.0 8612 1904 ? S 00:27 0:00 postgres:
stats buffer process
postgres 11778 0.0 0.0 7620 1928 ? S 00:27 0:00 postgres:
stats collector process
postgres 12950 0.0 0.0 9132 4300 ? S 00:27 0:00 postgres:
dcm1104_root mkim_org 127.0.0.1 idle
postgres 13152 0.0 0.0 8436 3748 ? S 00:27 0:00 postgres:
dcm1104_root mkim_org 127.0.0.1 idle
postgres 13216 0.0 0.0 8436 3644 ? S 00:27 0:00 postgres:
dcm1104_root mkim_org 127.0.0.1 idle
postgres 13410 0.0 0.0 8036 2952 ? S 00:27 0:00 postgres:
dcm1104_root mkim_org 127.0.0.1 idle
postgres 13474 0.0 0.0 8436 3940 ? S 00:27 0:00 postgres:
dcm1104_root mkim_org 127.0.0.1 idle
postgres 13664 0.0 0.0 8420 3796 ? S 00:27 0:00 postgres:
dcm1104_root mkim_org 127.0.0.1 idle
postgres 13824 0.0 0.0 8040 3024 ? S 00:27 0:00 postgres:
dcm1104_root mkim_org 127.0.0.1 idle
postgres 13890 0.0 0.0 8436 3984 ? S 00:27 0:00 postgres:
dcm1104_root mkim_org 127.0.0.1 idle
postgres 2466 0.0 0.0 8432 3764 ? S 00:31 0:00 postgres:
dcm1104_root mkim_org 127.0.0.1 idle
postgres 2535 0.0 0.0 8568 3960 ? S 00:31 0:00 postgres:
dcm1104_root mkim_org 127.0.0.1 idle
postgres 19026 0.0 0.0 8040 2940 ? S 01:11 0:00 postgres:
dcm1104_root mkim_org 127.0.0.1 idle

i have tried both pg_connect and pg_pconnect, and this happens either
way. I don't understand why it keeps starting more processes when there
are others sitting around doing nothing??? Any thoughts?

Thanks

Dan

Jul 19 '05 #1
Share this Question
Share on Google+
1 Reply

P: n/a
Dan <no****@aol.com> scribbled on the stall wall:
I have a server under very light load -- just me doing some work in php.
I am getting this error often and don't know why:

postgresql max connections Unable to connect to PostgreSQL server:
FATAL: Sorry, too many clients already

my postgresql.conf had:

max_connections = 8
shared_buffers = 16

I changed those to 32 and 64 and it is working so far. But I have a
bunch of postgresses running now with all of them doing almost nothing:

are you starting a new (connection) for each transaction? If so, don't
do that. what you're seeing is proably a consequence of your php interface
but without seeing the exact code we have no way of knowing.

--
dual 2.8Ghz Xeon; 2GB RAM; 500GB ATA-133; nVidia powered
Linux 2.6.10; glibc-2.3.5; vendor neutral home-brewed installation

----anything after this line is ANNOYING CRAP that the newsserver adds-----
---directly contact newsfeeds and ISPs that piggy back them to complain----
----== Posted via Newsfeeds.Com - Unlimited-Uncensored-Secure Usenet News==----
http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
----= East and West-Coast Server Farms - Total Privacy via Encryption =----
Jul 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.