By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,962 Members | 2,036 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,962 IT Pros & Developers. It's quick & easy.

How to find out that SSL is activated

100+
P: 111
Im trying to connect frm Mysql to postgresql thru ssh,

the connection string is as follows:
Expand|Select|Wrap|Line Numbers
  1.  
  2.  
  3.  ' code to update the data with required fields into the post gre data base 
  4.         Dim myPgrConnect As New NpgsqlConnection
  5.         Dim myPgrCommand As New NpgsqlCommand
  6.         Dim strSQL As String
  7.         Dim record As String
  8.         Dim intRowsAffected As Integer
  9.         Dim ds As New DataSet
  10.         Dim myTable As DataTable
  11.         Try
  12.             If Plink.HasExited = False Then
  13.                 myPgrConnect.ConnectionString = "Server=localhost; Port=5432; Database=dalitch_uk; Userid=dalitch_web; Password=dfndev; Protocol=3; SSL=true; Pooling=true; MinPoolSize=1; MaxPoolSize=20; Encoding=UNICODE; Timeout=25; SslMode=Prefer;"
  14.   ..........[error]---------myPgrConnect.Open()..................>>>[eeror]
  15.             End If
  16.  
can anyone tell me teh solution..

thnx
May 28 '07 #1
Share this Question
Share on Google+
3 Replies


Expert 100+
P: 534
Is this the same problem that we discussed few days ago?

I thought you indicated that replacing the "localhost" with the actual IP address in the connection string solved all your problems...
May 29 '07 #2

100+
P: 111
Is this the same problem that we discussed few days ago?

I thought you indicated that replacing the "localhost" with the actual IP address in the connection string solved all your problems...

No.... tht dint work!!!!!!

Now my problem is with postgresql..... im trying to use postgresql through plesk...
even when im trying to give the actual IP adress with correct user id and password.. im getting an error:

No connection could be made because the target machine actively refused it.
May 29 '07 #3

Expert 100+
P: 534
Make sure you don't have a firewall blocking TCP/IP on given port.
Look at the database log, check for messages about rejected connections.
Review your pg_hba.conf and postgresql.conf, read these links for more information on authentication and connections.

http://www.postgresql.org/docs/8.1/s...onnection.html
http://www.postgresql.org/docs/8.1/i...ntication.html

I would also try SSL=false in the connection string, the Postgres SSL connection settings can be found in your pg_hba.conf file.
Jun 5 '07 #4

Post your reply

Sign in to post your reply or Sign up for a free account.