By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,852 Members | 2,200 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,852 IT Pros & Developers. It's quick & easy.

phpPgAdmin problem - this list?

P: n/a
I'm not sure if this is really on topic for this list but I'll start
here.

I'm trying to run phpPgAdmin, I've installed version 3.5, I have
postgresql version 7.4.3 running on slackware 9.1.

I already have phpMyAdmin running successfully.

When I try and run phpPgAdmin I get:-

"Your PHP installation does not support PostgreSQL. You need to
recompile PHP using the --with-pgsql configure option."

However the /usr/lib/php/extensions directory *has* got the pgsql.so
library file, so can anyone suggest what might be wrong? Or
alternatively point me to somewhere better to ask?

--
Chris Green (ch***@areti.co.uk)

"Never ascribe to malice, that which can be explained by incompetence."

---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 23 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
> However the /usr/lib/php/extensions directory *has* got the pgsql.so
library file, so can anyone suggest what might be wrong? Or
alternatively point me to somewhere better to ask?


Try one of the php lists. But check that the extension is enabled in the
php.ini first (uncomment the extension=pgsql.so line).

Matt

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 23 '05 #2

P: n/a
On Fri, Nov 19, 2004 at 07:23:08PM +0000, Matt wrote:
However the /usr/lib/php/extensions directory *has* got the pgsql.so
library file, so can anyone suggest what might be wrong? Or
alternatively point me to somewhere better to ask?


Try one of the php lists. But check that the extension is enabled in the
php.ini first (uncomment the extension=pgsql.so line).

Excellent, that was it, thanks very much, it's saved me some time
hunting elsewhere. Strangely phpMyAdmin doesn't need the mysql.so
extension enabled but phpPgAdmin does.

--
Chris Green (ch***@areti.co.uk)

"Never ascribe to malice, that which can be explained by incompetence."

---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 23 '05 #3

P: n/a
Chris Green wrote:
On Fri, Nov 19, 2004 at 07:23:08PM +0000, Matt wrote:

However the /usr/lib/php/extensions directory *has* got the pgsql.so
library file, so can anyone suggest what might be wrong? Or
alternatively point me to somewhere better to ask?

Try one of the php lists. But check that the extension is enabled in the
php.ini first (uncomment the extension=pgsql.so line).

Excellent, that was it, thanks very much, it's saved me some time
hunting elsewhere. Strangely phpMyAdmin doesn't need the mysql.so
extension enabled but phpPgAdmin does.

That is because PHP compiles in mysql by default :).

Sincerely,

Joshua D. Drake

--
Command Prompt, Inc., home of Mammoth PostgreSQL - S/ODBC and S/JDBC
Postgresql support, programming shared hosting and dedicated hosting.
+1-503-667-4564 - jd@commandprompt.com - http://www.commandprompt.com
PostgreSQL Replicator -- production quality replication for PostgreSQL

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 23 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.