By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,903 Members | 1,104 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,903 IT Pros & Developers. It's quick & easy.

Moving from 7.x to 8.0beta4 with a backup

P: n/a
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I had been running 7.x under cygwin (about 2 versions behind the latest
cygwin has), but cygserver stopped running on my last cygwin update, and
it seemed easier to move to 8.0 than to coax cygserver back to life.
Fortunately, I had a quite recent pg_dumpall, so I installed 8.0
(easy!), created a test database and verified I could do something, and
then set about restoring from my backup.

It appears that Tools > Backup or Tools > Restore in pgAdmin works at
the database level, not for everything on the server, so I tried

/pathtobeta4/psql.exe template1 < database.backup

It prints

$ /cygdrive/c/Program\ Files/PostgreSQL/8.0.0-beta4/bin/psql.exe template1 < da
tabase.backup
Password:
psql: FATAL: password authentication failed for user "user name"

where user name is the name of the user created in database.backup
(unfortunately, I had put no password on my cygwin installation). I
tried adding a -W option to psql, to no avail. I tried creating a user
of the proper name in pgAdmin and giving a password -- or no password,
to no avail. I tried adding ... PASSWORD 'thepassword' ... in the
CREATE USER statement in database.backup, to no avail.

Any suggestions? I'm guessing it's an easy answer that just escapes me.

<*>

Once I get that done, I might as well get rid of the cygwin PostgreSQL.
Is there any problem in simply uninstalling it using cygwin setup?

Thanks,

Bill
- --
Bill Harris
Facilitated Systems
http://facilitatedsystems.com/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (MingW32)
Comment: For more information, see http://www.gnupg.org

iD8DBQFBm3l13J3HaQTDvd8RAns8AJ9ufqK+dfpMpZ2DH3gdCB 6On+sGpQCdEO/B
VFXSisxbjzJtOku/wWvgg78=
=X3f2
-----END PGP SIGNATURE-----
Nov 23 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Bill Harris <bi*********@facilitatedsystems.com> writes:
$ /cygdrive/c/Program\ Files/PostgreSQL/8.0.0-beta4/bin/psql.exe template1 < da
tabase.backup
Password:
psql: FATAL: password authentication failed for user "user name"


It was a relatively easy answer. I temporarily edited pg_hba.conf to
allow users without passwords, I created the user in question, and I
made small edits to the start of my backup file, and it all worked well.

Bill
--
Bill Harris
Facilitated Systems
http://facilitatedsystems.com/
Nov 23 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.