470,833 Members | 1,389 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,833 developers. It's quick & easy.

autovacuum redhat startup

I reconfigured the redhat startup script for postgresql to work with
version 8 and that is working fine.
I thought I could put autovacuum in the startup script and that didn't
cause any problems, but it didn't turn on and I had to start it
manually.

Does anyone know why it didn't catch? I was watching the bootup and it
seemed that the program was actually called. (a screen flew by my eyes
very quickly but since it was the last thing, I didn't see for sure
that it was the autovacuum starting output).

The startup script is in the /etc/rc.d/init.d directory and I put the
autovacuum line after the line echoing that it started. I stopped and
started the script manually and autovacuum did start.

If this can not be accomplished in the same script is there a way to
have it start on server startup?
Thank You
Sim Zacks
IT Manager
CompuLab
04-829-0145 - Office
04-832-5251 - Fax
---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 23 '05 #1
0 2361

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Mau | last post: by
1 post views Thread by Socketd | last post: by
1 post views Thread by Michael A. Miller | last post: by
4 posts views Thread by D. Dante Lorenso | last post: by
1 post views Thread by Steve Crawford | last post: by
reply views Thread by Sim Zacks | last post: by
reply views Thread by Assyst | last post: by
reply views Thread by mihailmihai484 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.