By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,710 Members | 1,887 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,710 IT Pros & Developers. It's quick & easy.

8.0 Beta 4 denying network connections?

P: n/a
Hello,

I've got one 7.4 installation and a brand new 8.0 beta4
running on the same machine.

Both installations are configured to use the same port
(5431) to avoid reconfiguring the apps running on
top of the DB.

The following paragraphs illustrate the problem:

[root@mymachine root 20:52:07]# service postgres74 start
Starting PostgreSQL: ok

[vinko@mymachine sources 20:54:36]$ telnet mymachine 5431
Trying 192.168.2.69...
Connected to mymachine.mydomain.cl (192.168.0.169).
Escape character is '^]'.
null
Connection closed by foreign host.

[root@mymachine root 20:55:50]# service postgres74 stop
Stopping PostgreSQL: ok
[root@mymachine root 20:55:56]# service postgres8 start
Starting PostgreSQL: ok

[vinko@mymachine sources 20:55:07]$ telnet mymachine 5431
Trying 192.168.0.169...
telnet: Unable to connect to remote host: Connection refused

If I try connecting from localhost, I can connect without
trouble in both versions.

And, of course, the same happens with the psql client.

I tried modifying pg_hba.conf but to no avail and what I have
looks right to me.

Has the syntax for this file changed? I even tried to use the 74's
pg_hba with 80, but the results are the same.

Is there another config option I'm missing? FWIW, beta3 doesn't
behave this way.

Thanks for any insight on the issue,
--
Vinko Vrsalovic <el[|-@-|]vinko.cl>

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 23 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Vinko Vrsalovic <el@vinko.cl> writes:
[vinko@mymachine sources 20:55:07]$ telnet mymachine 5431
Trying 192.168.0.169...
telnet: Unable to connect to remote host: Connection refused


Looks to me like you forgot to enable TCP connections in the 8.0
installation. Note that the relevant postgresql.conf options are
not the same in 8.0 as 7.4 (see listen_addresses vs tcpip_socket
and virtual_host).

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 23 '05 #2

P: n/a
On Fri, Oct 29, 2004 at 09:59:17PM -0400, Tom Lane wrote:
Vinko Vrsalovic <el@vinko.cl> writes:
[vinko@mymachine sources 20:55:07]$ telnet mymachine 5431
Trying 192.168.0.169...
telnet: Unable to connect to remote host: Connection refused


Looks to me like you forgot to enable TCP connections in the 8.0
installation. Note that the relevant postgresql.conf options are
not the same in 8.0 as 7.4 (see listen_addresses vs tcpip_socket
and virtual_host).


Shame on me, I checked the file 6 times and every time read "defaults to
'*' = any".

Thanks a lot,
--
Vinko Vrsalovic <el[|-@-|]vinko.cl>

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 23 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.