By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,541 Members | 1,455 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,541 IT Pros & Developers. It's quick & easy.

Resource temporarily unavailable

P: n/a
Hi everyone

From time to time i get the following error:
could not fork new process for connection: Resource temporarily unavailable

im using Postgres 7.4.5, with kernel 2.6.2

my conf is:

max_connections = 400

and system is:

www3:/etc/postgresql# ulimit -a
core file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
file size (blocks, -f) unlimited
max locked memory (kbytes, -l) unlimited
max memory size (kbytes, -m) unlimited
open files (-n) 1024
pipe size (512 bytes, -p) 8
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) 256
virtual memory (kbytes, -v) unlimited

im totaly bogus, any ideas ?

Thanks
--------------------------
Canaan Surfing Ltd.
Internet Service Providers
Ben-Nes Michael - Manager
Tel: 972-4-6991122
Fax: 972-4-6990098
http://www.canaan.net.il
--------------------------

---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 23 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
"Ben-Nes Michael" <mi**@canaan.co.il> writes:
From time to time i get the following error:
could not fork new process for connection: Resource temporarily unavailable
This generally means that the kernel has run out of memory.
my conf is:
max_connections = 400


Perhaps that is overly optimistic for your available hardware.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

http://archives.postgresql.org

Nov 23 '05 #2

P: n/a
>
max_connections = 400

www3:/etc/postgresql# ulimit -a
max user processes (-u) 256 im totaly bogus, any ideas ?


Well, your allowing postgres to have 400 connection which is at least 400 processes if not a few more.
And you are ulimiting the postgres user to 256 processes. So the kernel says out of process space for that user.

Regards

Russell Smith

---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

http://archives.postgresql.org

Nov 23 '05 #3

P: n/a
> >
max_connections = 400

www3:/etc/postgresql# ulimit -a
max user processes (-u) 256
im totaly bogus, any ideas ?


Well, your allowing postgres to have 400 connection which is at least 400

processes if not a few more. And you are ulimiting the postgres user to 256 processes. So the kernel says out of process space for that user.

Its the default values. can any one hint me where to change this ?

Regards

Russell Smith


--------------------------
Canaan Surfing Ltd.
Internet Service Providers
Ben-Nes Michael - Manager
Tel: 972-4-6991122
Fax: 972-4-6990098
http://www.canaan.net.il
--------------------------
---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 23 '05 #4

P: n/a
> >
max_connections = 400

www3:/etc/postgresql# ulimit -a
max user processes (-u) 256
im totaly bogus, any ideas ?


Well, your allowing postgres to have 400 connection which is at least 400

processes if not a few more. And you are ulimiting the postgres user to 256 processes. So the kernel says out of process space for that user.

Its the default values. can any one hint me where to change this ?

Regards

Russell Smith


--------------------------
Canaan Surfing Ltd.
Internet Service Providers
Ben-Nes Michael - Manager
Tel: 972-4-6991122
Fax: 972-4-6990098
http://www.canaan.net.il
--------------------------
---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 23 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.