By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,773 Members | 1,724 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,773 IT Pros & Developers. It's quick & easy.

How to increase number of connections to 7.2.1

P: n/a
I need to increase the number of connections to PostgreSQL 7.2.1.

I have tried changing the value of max_connections in Postgresql.conf. It
was commented out (as are all other entries except "tcpip_socket = true").
Setting it to any other value that the default 32 resulted in the server
failing to restart.

I know we should upgrade from 7.2.1 and that is going to happen soon, but
this is a production server and I need a solution sooner.

Thanks in advance,
Edwin New
Analyst Programmer
Toll - Integrated Business Systems
43 - 63 Princes Highway,
Doveton, VIC. 3175
Ph: 03 8710 0858
Fax: 03 9793 3970
Mobile: 0417 341 074
Email: ed*******@toll.com.au
Nov 23 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
On Mon, 2004-10-18 at 11:15, Edwin New wrote:
I have tried changing the value of max_connections in
Postgresql.conf. It was commented out (as are all other entries
except "tcpip_socket = true"). Setting it to any other value that the
default 32 resulted in the server failing to restart.


Without knowing the error message you got, it's possible that you didn't
increase shared_buffers to correspond to the newly increased
max_connections. If you increase shared_buffers, then you're probably
exceeding the system SysV shared memory restrictions. See

http://www.postgresql.org/docs/7.4/s...s.html#SYSVIPC

-Neil

---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 23 '05 #2

P: n/a
Edwin New <ed*******@toll.com.au> writes:
I need to increase the number of connections to PostgreSQL 7.2.1.
I have tried changing the value of max_connections in
Postgresql.conf. It was commented out (as are all other entries
except "tcpip_socket = true"). Setting it to any other value that the
default 32 resulted in the server failing to restart.


1) Make sure your shared_buffers setting is big enough to handle your
desired connection limit.

2) Make sure your kernel's shared memory limits allow for your
shared_buffers setting.

If you can't get it to start, please post the server log entries from
the failed attempt--otherwise we have nothing to go on.

-Doug
--
Let us cross over the river, and rest under the shade of the trees.
--T. J. Jackson, 1863

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 23 '05 #3

P: n/a
What error do you get when the server fails to restart? It sounds like
it could be a kernel resource issue. See:

http://www.postgresql.org/docs/7.4/s...resources.html

-tfo

On Oct 17, 2004, at 8:15 PM, Edwin New wrote:
I need to increase the number of connections to PostgreSQL 7.2.1.

*

I have tried changing the value of max_connections in
Postgresql.conf.* It was commented out (as are all other entries
except "tcpip_socket = true"). *Setting it to any other value that the
default 32 resulted in the server failing to restart.

*

I know we should upgrade from 7.2.1 and that is going to happen soon,
but this is a production server and I need a solution sooner.

*

Thanks in advance,

Edwin New
Analyst Programmer


---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 23 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.