By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,691 Members | 1,997 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,691 IT Pros & Developers. It's quick & easy.

external function libraries on non-build machine

P: n/a
I have built slony 1.0.2 with postgres 7.4.5. This needs to be deployed
on a system other than the one on which is was built. Somebody on our
team had earlier gotten around the problem of not being able to move a
postgres install by manually updating the pg_catalog.pg_proc table. But
it seems like this worked *after* the procs calling external libraries
were installed. With the slony stuff I can't install the procs until the
database has been deployed on its target machine, so that hack doesn't
seem to help me.

Now I'm trying to run a slonik script on the new system, and I am
getting the following error, which I assume is because $libdir no longer
references the build file system:

<stdin>:3: Initializing the cluster
<stdin>:5: PGRES_FATAL_ERROR load '$libdir/xxid'; - ERROR: could not
access file "$libdir/xxid": No such file or directory
<stdin>:5: Error: the extension for the xxid data type cannot be loaded
in database 'dbname=test1 host=engtst port=24005 user=slony
password=slony'
<stdin>:7: Could not initialize the cluster!

I'm a little bit desperate, hence the cross-post. Is there anything I
can do on the target system to fix up the slony sql files to get them
installable in the new environment? I've tried setting the "AS
$libdir/xxid' clauses to various strings with full paths, but I don't
seem to be getting it.

Thank you for any help. Apologies for the cross-post.

- DAP
================================================== ====
David Parker Tazz Networks (401) 709-5130
---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 23 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.