By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,542 Members | 1,434 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,542 IT Pros & Developers. It's quick & easy.

install problem

P: n/a
I am using SuSE 8.0 Professional Linux and installing
postresql 7.4 by placing the tar files in /temp and
untar and unzip and followed the short install
procedure.
Log in as root
../ configure
gmake
gmake install
useradd
mkdir /usr/local/pgsql/data
chown postgres /usr/local/pgsql/data
su postgres
/usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data
""same as above"" >logfile 2>&1 &

At this point I checked the last 2 lines to enter and
was told I do not have the password for the postges
sence it is not a person but a program it should not
ask for the password. Have not had sucess to call up
the program or to finish the last 2 lines.
/usr/local/pgsql/bin/createdb test
/usr/local/pgsql/bin/pgsql test

What can I do to finish the last 2 lines and call up
the potgres or pgsql?


_______________________________
Do you Yahoo!?
Declare Yourself - Register online to vote today!
http://vote.yahoo.com

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 23 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
wayne schlemitz <sc*******@yahoo.com> writes:
What can I do to finish the last 2 lines and call up
the potgres or pgsql?


We can't help you from such a handwavy description. Show us *exactly*
what you typed and *exactly* what messages you got (cut-and-paste from
your terminal window is good), and then we might be able to offer
better-than-guessing answers.

I'd also suggest looking in the postmaster logfile to see if there are
any informative messages there.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 23 '05 #2

P: n/a

If I understand your description of the problem sufficiently, I believe
you're
running into trouble at the "su postres" step.

Although I'm quite new to postgres, I do know that creating a user
account
named "postgres" is recommended, if not required, by the installation
process.
Entering "su postgres" on the cmd-line switches the user (su) in that
shell to
username: postgres -- it's not invoking a program, per se. Then
logging in,
even via su, requires password authentication.

Hope this helps -
Scott

On Oct 9, 2004, at 7:29 AM, wayne schlemitz wrote:
I am using SuSE 8.0 Professional Linux and installing
postresql 7.4 by placing the tar files in /temp and
untar and unzip and followed the short install
procedure.
Log in as root
./ configure
gmake
gmake install
useradd
mkdir /usr/local/pgsql/data
chown postgres /usr/local/pgsql/data
su postgres
/usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data
""same as above"" >logfile 2>&1 &

At this point I checked the last 2 lines to enter and
was told I do not have the password for the postges
sence it is not a person but a program it should not
ask for the password. Have not had sucess to call up
the program or to finish the last 2 lines.
/usr/local/pgsql/bin/createdb test
/usr/local/pgsql/bin/pgsql test

What can I do to finish the last 2 lines and call up
the potgres or pgsql?


_______________________________
Do you Yahoo!?
Declare Yourself - Register online to vote today!
http://vote.yahoo.com

---------------------------(end of
broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 23 '05 #3

P: n/a
Dear Wayne,

Hum! you are not following exactly the instructions for a "Short Installation"
which is:
../configure
gmake
su
gmake install
adduser postgres
mkdir /usr/local/pgsql/data
chown postgres /usr/local/pgsql/data
su - postgres
/usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data
/usr/local/pgsql/bin/postmaster -D /usr/local/pgsql/data >logfile 2>&1 &
/usr/local/pgsql/bin/createdb test
/usr/local/pgsql/bin/psql test

Anyway, what did you enter after "useradd"?
That command requires at least one parameter, the new user name
which in this case should be postgres.

Once that is done, the "su postgres" will work without any password since
you are running it from root.

Regards,

Bernard

On Saturday 09 October 2004 10:29, wayne schlemitz wrote:
I am using SuSE 8.0 Professional Linux and installing
postresql 7.4 by placing the tar files in /temp and
untar and unzip and followed the short install
procedure.
Log in as root
./ configure
gmake
gmake install
useradd
mkdir /usr/local/pgsql/data
chown postgres /usr/local/pgsql/data
su postgres
/usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data
""same as above"" >logfile 2>&1 &

At this point I checked the last 2 lines to enter and
was told I do not have the password for the postges
sence it is not a person but a program it should not
ask for the password. Have not had sucess to call up
the program or to finish the last 2 lines.
/usr/local/pgsql/bin/createdb test
/usr/local/pgsql/bin/pgsql test

What can I do to finish the last 2 lines and call up
the potgres or pgsql?


_______________________________
Do you Yahoo!?
Declare Yourself - Register online to vote today!
http://vote.yahoo.com

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 23 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.