467,173 Members | 1,394 Online
Bytes | Developer Community
Ask Question

Home New Posts Topics Members FAQ

Post your question to a community of 467,173 developers. It's quick & easy.

psql error - "unrecognizable command" V8.0.0 beta

Hi,

I've run into a problem. I've had postgres V8 beta on my WinXP Pro machine
for some time now, and it's been running great. Now, for some reason, I
cannot issue any queries to the database via psql. See snippit below...

------------
C:\Program Files\PostgreSQL\8.0-beta1\bin>createdb -U postgres test
CREATE DATABASE

C:\Program Files\PostgreSQL\8.0-beta1\bin>psql -d test -U postgres
Welcome to psql 8.0.0beta1, the PostgreSQL interactive terminal.

Type: \copyright for distribution terms
\h for help with SQL commands
\? for help with psql commands
\g or terminate with semicolon to execute query
\q to quit

Warning: Console codepage (850) differs from windows codepage (1252)
8-bit characters will not work correctly. See PostgreSQL
documentation "Installation on Windows" for details.

test=# select now();
'more' is not recognized as an internal or external command,
operable program or batch file.
test=#
-------------

The message regarding the 'more' command is the same no matter what query is
issued. I also get it anytime I try to restore a database from a dump
(wherever a setval command is issued).

I've tried reinstalling the db to no avail. This problem does not repeat
itself on other machines! Does anyone have any ideas?

Thanks
Peter
---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 23 '05 #1
  • viewed: 1973
Share:
3 Replies
"Anony Mous" <A.****@shaw.ca> writes:
test=# select now();
'more' is not recognized as an internal or external command,
operable program or batch file.


Looks to me like psql is trying to use "more" to paginate the query
output, and it ain't there. "more" is the default on Unix but I dunno
what we should use on Windows. Anyway, see the psql man page and read
about the "pager" variable to change this.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 23 '05 #2
On Wed, 15 Sep 2004 13:52:17 -0600, "Anony Mous" <A.****@shaw.ca> wrote:
I've tried reinstalling the db to no avail. This problem does not repeat
itself on other machines! Does anyone have any ideas?


does more.com exist in a directory on the path (usually
%systemroot%\system32)?

klint.

+---------------------------------------+-----------------+
: Klint Gore : "Non rhyming :
: EMail : kg@kgb.une.edu.au : slang - the :
: Snail : A.B.R.I. : possibilities :
: Mail University of New England : are useless" :
: Armidale NSW 2351 Australia : L.J.J. :
: Fax : +61 2 6772 5376 : :
+---------------------------------------+-----------------+

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 23 '05 #3
Well, as I mentioned, I cannot reproduce this problem on other PC's running
Win 2K or XP. It must be a system path issue on my PC. I can't test it
right now, but I'll try ensuring that the system knows where to find the
"more" executable and try it again.

Much thanks.
----- Original Message -----
From: "Tom Lane" <tg*@sss.pgh.pa.us>
To: "Anony Mous" <A.****@shaw.ca>
Cc: <pg***********@postgresql.org>
Sent: Wednesday, September 15, 2004 7:56 PM
Subject: Re: [GENERAL] psql error - "unrecognizable command" V8.0.0 beta

"Anony Mous" <A.****@shaw.ca> writes:
test=# select now();
'more' is not recognized as an internal or external command,
operable program or batch file.


Looks to me like psql is trying to use "more" to paginate the query
output, and it ain't there. "more" is the default on Unix but I dunno
what we should use on Windows. Anyway, see the psql man page and read
about the "pager" variable to change this.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 23 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Arepi | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.