469,627 Members | 1,068 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,627 developers. It's quick & easy.

pgadmin problem

mmd
I want to use pgadmin to set up some tables, rather than do all the
psql statements from the terminal.

When I try to add a server, though, pgadmin fails to connect, and asks
whether the server is accepting TCP/IP connections on the default
port, and whether localhost is the correct servername.

I assume that both of these ARE set to the defaults, because if I
simply type

$ psql contacts

I go right into psql, where I am allowed to make and alter tables.

Is there something along the lines of a "psql -v" that would tell
me what the server calls itself, and what ports it's listening on (oh,
and whether it's allowing TCP/IP connections)?

If not, is there better help on this pgadmin3 dialogue somewhere? The
stock documentation is very thin.

Best,
Matt

--

Matthew M Davis
<mm*@teledavis.com>

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 23 '05 #1
2 1799
mm*@teledavis.com writes:
I want to use pgadmin to set up some tables, rather than do all the
psql statements from the terminal.

When I try to add a server, though, pgadmin fails to connect, and asks
whether the server is accepting TCP/IP connections on the default
port, and whether localhost is the correct servername.

I assume that both of these ARE set to the defaults, because if I
simply type

$ psql contacts

I go right into psql, where I am allowed to make and alter tables.


The server doesn't use TCP/IP by default. You can change this by
editing the postgresql.conf file in the server's data directory (the
location of which varies depending on how PG was installed) and
setting 'tcpip_socket' to 'true', then restarting the server.

You may also need to edit pg_hba.conf, depending on whether you're
connecting from the local machine and how you have your databases set
up.

-Doug

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 23 '05 #2
On Fri, 2004-07-23 at 13:58, mm*@teledavis.com wrote:
I want to use pgadmin to set up some tables, rather than do all the
psql statements from the terminal.

When I try to add a server, though, pgadmin fails to connect, and asks
whether the server is accepting TCP/IP connections on the default
port, and whether localhost is the correct servername.

I assume that both of these ARE set to the defaults, because if I
simply type

$ psql contacts

I go right into psql, where I am allowed to make and alter tables.


In that case you are not using TCP/IP to localhost, but a Unix socket.
Try "psql -h localhost contacts" to see the difference.

Edit $PGDATA/pg_hba.conf to change the settings (and then signal the
postmaster or restart it).

--
Oliver Elphick ol**@lfix.co.uk
Isle of Wight http://www.lfix.co.uk/oliver
GPG: 1024D/A54310EA 92C8 39E7 280E 3631 3F0E 1EC0 5664 7A2F A543 10EA
========================================
"Be not deceived; God is not mocked; for whatsoever a
man soweth, that shall he also reap."
Galatians 6:7
---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 23 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Matthew T. O'Connor | last post: by
1 post views Thread by Együd Csaba | last post: by
1 post views Thread by raptor | last post: by
2 posts views Thread by Vic Cekvenich | last post: by
reply views Thread by Laurent Duperval | last post: by
reply views Thread by gheharukoh7 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.