469,923 Members | 1,781 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,923 developers. It's quick & easy.

PGADMIN default storage EXTENDED for Character fields



I am using PGADMIN III v1.1.0 Windows to set up PostgreSQL tables on a
Linux Server, RedHat 9. Every time I create a character field, even just
one character wide, the PGADMIN uses EXTENDED as the default storage type.
Is this normal? I can't find anything about why this would be done in the
PostgreSQL documentation or the Internet. It seems to me it will be very
messy if every character field is in a secondary table. I would have
thought the EXTENDED would only be for very large character fields.

*** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
***
Margaret Gillon, IS Dept., Chromalloy Los Angeles, ext. 297
---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 23 '05 #1
1 3205
Ma************@chromalloy.com writes:
I am using PGADMIN III v1.1.0 Windows to set up PostgreSQL tables on a
Linux Server, RedHat 9. Every time I create a character field, even just
one character wide, the PGADMIN uses EXTENDED as the default storage type.
Is this normal?
Yes, this is the standard behavior.
It seems to me it will be very messy if every character field is in a
secondary table. I would have thought the EXTENDED would only be for
very large character fields.


No, you are misunderstanding. EXTENDED storage *allows* Postgres to
move large field values out to a secondary table. If a particular entry
is not large, then it won't be moved out.

Choosing one of the other storage options restricts Postgres from moving
data out, which can make things faster but also exposes you to a risk of
"row too large" errors. So I'd not recommend doing it unless you are
quite sure you know what you're doing and what your data will look like.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 23 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

22 posts views Thread by Keith MacDonald | last post: by
1 post views Thread by Egyd Csaba | last post: by
12 posts views Thread by Jeremy | last post: by
2 posts views Thread by raptor | last post: by
2 posts views Thread by mmd | last post: by
13 posts views Thread by ramif | last post: by
reply views Thread by Waqarahmed | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.