467,150 Members | 1,147 Online
Bytes | Developer Community
Ask Question

Home New Posts Topics Members FAQ

Post your question to a community of 467,150 developers. It's quick & easy.

FW: problems with installing postgres


Forwarding to the mailing list, as I don't know how to fix it....

------ Forwarded Message
From: Henning Klein <kl****@rz.uni-potsdam.de>
Date: Tue, 22 Jun 2004 22:09:08 +0200
To: aw*****@sghms.ac.uk
Subject: problems with installing postgres

hi,

i have major problems installing pgsql on a mac using mac os x 10.2.8.
everytime i try to start initdb after finishing my installation the mac
says:
The files belonging to this database system will be owned by user
"postgres".
This user must also own the server process.

The database cluster will be initialized with locale de_DE.

fixing permissions on existing directory /usr/local/pgsql/data/... ok
creating directory /usr/local/pgsql/data//base... ok
creating directory /usr/local/pgsql/data//global... ok
creating directory /usr/local/pgsql/data//pg_xlog... ok
creating directory /usr/local/pgsql/data//pg_clog... ok
selecting default max_connections... 50
selecting default shared_buffers... 300
creating configuration files... ok
creating template1 database in /usr/local/pgsql/data//base/1... FATAL:
invalid value for parameter "lc_time": "de_DE"

initdb: failed

the postgre documentation does not give any answer how to initialize a
database without localization. do you have an idea, how to fix my
problem?

regards henning klein

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.
---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 23 '05 #1
  • viewed: 1511
Share:
2 Replies
Adam Witney wrote:
Forwarding to the mailing list, as I don't know how to fix it....

------ Forwarded Message
From: Henning Klein <kl****@rz.uni-potsdam.de> i have major problems installing pgsql on a mac using mac os x 10.2.8.
everytime i try to start initdb after finishing my installation the mac
says: .... The database cluster will be initialized with locale de_DE. .... creating template1 database in /usr/local/pgsql/data//base/1... FATAL:
invalid value for parameter "lc_time": "de_DE"


Well, you can run initdb with different locales:
initdb --locale=C
Or, you could just override the invalid time locale:
initdb --lc-time=<CORRECT ZONE HERE>

Now, why de_DE isn't valid, I don't know. Try the output of "locale"
from the command-prompt and see what that says about it.

--
Richard Huxton
Archonet Ltd

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 23 '05 #2
Richard Huxton <de*@archonet.com> writes:
Now, why de_DE isn't valid, I don't know.


We've seen reports of this kind before --- it appears that the locale
support in OS X 10.2.* is rather incomplete. I don't recall having
heard any similar reports concerning 10.3 though, so maybe the best
answer is an upgrade to Panther. (In the meantime though, you can
work around it as Richard suggests.)

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 23 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by javier garcia - CEBAS | last post: by
2 posts views Thread by Christopher Murtagh | last post: by
4 posts views Thread by Lynn.Tilby@asu.edu | last post: by
7 posts views Thread by Jerome Lyles | last post: by
3 posts views Thread by Marcel Boscher | last post: by
3 posts views Thread by zapov | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.