469,954 Members | 1,911 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,954 developers. It's quick & easy.

Error: server closed the connection unexpectedely

Hello everyone,

this is my first post to postgres mailing list.

System that I use:
I am using Postgres under last CygWin published on public mirrors at the moment.
OS system runing is Windows 2000 professional, 1024 or 256 or 512 MB of RAMand 40Gb of disk.
Postmaster shows version 7.4.1

Problem:
When trying to create database using script file (containing only create DB, USERS, TABLES, INDEXES inside tables) using psql or pgadminIII after awhile (5 seconds or so) I get next error:

server closed the connection unexpectedly
This probably means the server terminated abnormally
before or while processing the request.

in log file I get this:

LOG: server process (PID 1080) was terminated by signal 11
LOG: terminating any other active server processes
LOG: all server processes terminated; reinitializing
LOG: database system was interrupted at 2004-05-26 15:55:48 CEDT
LOG: checkpoint record is at 0/9DE7C8
LOG: redo record is at 0/9DE7C8; undo record is at 0/0; shutdown TRUE
LOG: next transaction ID: 534; next OID: 17142
LOG: database system was not properly shut down; automatic recovery in progress
LOG: redo starts at 0/9DE808
LOG: startup process (PID 1396) was terminated by signal 11
LOG: aborting startup due to startup process failure

This error happens sooner if I use pgadminIII and later if I use psql. I have instaled ipc-daemon2. I tried also with cygserver configuring enough memory, nothing happened.
I suspect error is somehow connected with size of one transaction. If transaction is small everything is OK. if transaction is large, this error happens.

I get the same error when doing vacuum analyze or when inserting larger amount of staff into database inside one transaction.

I tried to set next parameters from min to max in postgresql.conf but nothing helps (I get the same error).
shared_buffers = 10000
sort_mem = 2048
vacuum_mem = 8192
fsync = true
wal_buffers = 32
effective_cash_size = 5000
default_statistics_target = 50
tcpip_socket = true
max_connections = 32
other parameters are as default (I tried also with all parameters as default but problem remains the same).

I also tested memory (RAM), tests came out OK.


One interesting thing more:
On Linux RH8.0, Postgres 7.4.2 everything works fine. Also tried with the same postgresql.conf file on Linux,postgres 7.4.2. works ok, on Windows under CygWin, last postgres 7.4.1 have this error.




if somebody have a clue, what is going on here, please help.

Janez Kostanjsek
software engineer


Nov 23 '05 #1
1 4340
I believe this is a known problem with the cygwin version of 7.4.1.
7.4.2 should be available soon now that cygwin 1.5.10 has been
released. I believe their was a post in the pgsql-cygwin mailing list
from Jason Tishler with the reasons for waiting for 1.5.10.

Hopefully Jason can release 7.4.2 soon.
On Wed, 2004-05-26 at 09:17, Janez Kostanjšek wrote:
Hello everyone,

this is my first post to postgres mailing list.

System that I use:
I am using Postgres under last CygWin published on public mirrors at
the moment.
OS system runing is Windows 2000 professional, 1024 or 256 or 512 MB
of RAM and 40Gb of disk.
Postmaster shows version 7.4.1

Problem:
When trying to create database using script file (containing only
create DB, USERS, TABLES, INDEXES inside tables) using psql or
pgadminIII after awhile (5 seconds or so) I get next error:

server closed the connection unexpectedly
This probably means the server terminated abnormally
before or while processing the request.

in log file I get this:

LOG: server process (PID 1080) was terminated by signal 11
LOG: terminating any other active server processes
LOG: all server processes terminated; reinitializing
LOG: database system was interrupted at 2004-05-26 15:55:48 CEDT
LOG: checkpoint record is at 0/9DE7C8
LOG: redo record is at 0/9DE7C8; undo record is at 0/0; shutdown TRUE
LOG: next transaction ID: 534; next OID: 17142
LOG: database system was not properly shut down; automatic recovery
in progress
LOG: redo starts at 0/9DE808
LOG: startup process (PID 1396) was terminated by signal 11
LOG: aborting startup due to startup process failure

This error happens sooner if I use pgadminIII and later if I use psql.
I have instaled ipc-daemon2. I tried also with cygserver configuring
enough memory, nothing happened.
I suspect error is somehow connected with size of one transaction. If
transaction is small everything is OK. if transaction is large, this
error happens.

I get the same error when doing vacuum analyze or when inserting
larger amount of staff into database inside one transaction.

I tried to set next parameters from min to max in postgresql.conf but
nothing helps (I get the same error).
shared_buffers = 10000
sort_mem = 2048
vacuum_mem = 8192
fsync = true
wal_buffers = 32
effective_cash_size = 5000
default_statistics_target = 50
tcpip_socket = true
max_connections = 32
other parameters are as default (I tried also with all parameters as
default but problem remains the same).

I also tested memory (RAM), tests came out OK.


One interesting thing more:
On Linux RH8.0, Postgres 7.4.2 everything works fine. Also tried with
the same postgresql.conf file on Linux,postgres 7.4.2. works ok, on
Windows under CygWin, last postgres 7.4.1 have this error.




if somebody have a clue, what is going on here, please help.

Janez Kostanjsek
software engineer




---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 23 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Doug Durrett | last post: by
5 posts views Thread by =?Utf-8?B?V2VsdVI=?= | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.