By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,008 Members | 2,963 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,008 IT Pros & Developers. It's quick & easy.

initdb fails

P: n/a

Dear Sirs!

Every time I tried to run initdb I get

$ initdb
The files belonging to this database system will be owned by user "Taras".
This user must also own the server process.

The database cluster will be initialized with locale C.

fixing permissions on existing directory /usr/local/pgsql/data... ok
creating directory /usr/local/pgsql/data/base... ok
creating directory /usr/local/pgsql/data/global... ok
creating directory /usr/local/pgsql/data/pg_xlog... ok
creating directory /usr/local/pgsql/data/pg_clog... ok
selecting default max_connections... 10
selecting default shared_buffers... 50
creating configuration files... ok
creating template1 database in /usr/local/pgsql/data/base/1... FATAL: semctl(17
, 16, SETVAL, 536) failed: Invalid argument

initdb: failed

Could You be so kind to help me run PostgreSQL server?
I tried to run it under CygWin (CygIPC including, version 2.x, ipc-daemon2 &).
Configure, make & make install succeeded, but I can't initdb...

Thank You very much in advance!

Taras V. Panchenko.
Nov 23 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.