By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,709 Members | 2,155 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,709 IT Pros & Developers. It's quick & easy.

PostgreSQL 7.4.2 initdb problem

P: n/a
Hello All,

I installed postgresql 7.3.4 on HPUX PA in /usr/local/pgsql and put the libraries in
/usr/local/pgsql/lib/LIB_new. During the initialization( initdb), it loads libraries (language) from
/usr/local/pgsql/lib. In postgresql version 7.3.1, libraries are not loaded and no such problem during initdb.

I had the following problem:

$ initdb -D /var/pgsql
The files belonging to this database system will be owned by user "postgres".
This user must also own the server process.

The database cluster will be initialized with locale C.

fixing permissions on existing directory /var/pgsql... ok
creating directory /var/pgsql/base... ok
creating directory /var/pgsql/global... ok
creating directory /var/pgsql/pg_xlog... ok
creating directory /var/pgsql/pg_clog... ok
selecting default max_connections... 100
selecting default shared_buffers... 1000
creating configuration files... ok
creating template1 database in /var/pgsql/base/1... ok
initializing pg_shadow... ok
enabling unlimited row size for system tables... ok
initializing pg_depend... ok
creating system views... ok
loading pg_description... ok
creating conversions... ERROR: could not access file "$libdir/utf8_and_win874": No such file or directory

initdb: failed
$

When I have the libraries in /usr/local/pgsql/lib, there is no problem.

Is there any way to avoid like this?
I wants to install in /usr/local/pgsql and libraries in /usr/local/pgsql/lib/LIB_new directory. How to do this one?

Thanks,
raj.

Lycos Email has 10 MB of FREE storage space. http://mail.lycos.co.uk
---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 23 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
On Sun, Apr 25, 2004 at 04:18:22AM +0000, tech tech wrote:
Is there any way to avoid like this?
I wants to install in /usr/local/pgsql and libraries in /usr/local/pgsql/lib/LIB_new directory. How to do this one?


Did you give the --libdir switch to configure?

--
Alvaro Herrera (<alvherre[a]dcc.uchile.cl>)
"¿Cómo puedes confiar en algo que pagas y que no ves,
y no confiar en algo que te dan y te lo muestran?" (Germán Poo)

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 23 '05 #2

P: n/a
On Sun, Apr 25, 2004 at 04:18:22AM +0000, tech tech wrote:
Is there any way to avoid like this?
I wants to install in /usr/local/pgsql and libraries in /usr/local/pgsql/lib/LIB_new directory. How to do this one?


Did you give the --libdir switch to configure?

--
Alvaro Herrera (<alvherre[a]dcc.uchile.cl>)
"¿Cómo puedes confiar en algo que pagas y que no ves,
y no confiar en algo que te dan y te lo muestran?" (Germán Poo)

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 23 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.