By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
464,767 Members | 1,053 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 464,767 IT Pros & Developers. It's quick & easy.

\? not working in psql

P: n/a
Today I was using \e to edit the buffer, something I don't commonly do.
Somehow that screwed up my help file for psql.

When I do \?
instead of getting help for the slash commands I get

General
General
General
General
General
ull and not nosend;
Any thoughts?
The last line "ull and not nosend;" is part of what I was editing in the
buffer. The rest don't know where it came from.

---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 23 '05 #1
Share this Question
Share on Google+
2 Replies

P: n/a
Francisco Reyes <li***@natserv.com> writes:
Today I was using \e to edit the buffer, something I don't commonly do.
Somehow that screwed up my help file for psql.
When I do \?
instead of getting help for the slash commands I get
[junk]
Any thoughts?


The \? command just prints out a bunch of constant strings. The only
theory that comes to mind is that you mistakenly overwrote the file
of translated messages --- are you using a translation?

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 23 '05 #2

P: n/a
On Fri, 9 Apr 2004, Tom Lane wrote:

The \? command just prints out a bunch of constant strings. The only
theory that comes to mind is that you mistakenly overwrote the file
of translated messages --- are you using a translation?


No translation.
Quitting and coming back to psql did not help. However, quitting the xterm
session and starting a new one did the trick. \? is back to normal.

Thanks for the feedback. It was strange.

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 23 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.