By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
464,421 Members | 1,312 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 464,421 IT Pros & Developers. It's quick & easy.

No More Processes

P: n/a
I'm trying to run PostgreSQL 7.4.1 on Mac OS 10.2.6. I'm running into
problems when the number of process for the postgres user reaches 100.
When that happens I get a "No More Processes" message in the terminal
shell. From then on, that user is "locked". I can't even ssh into it.

I've tried to increase the max process limit in my startup script, but
I'm still getting the same behavior. Here's part of my script:
#!/bin/sh
.. /etc/rc.common

StartService ()
{
ulimit -u unlimited # before -u = 100
var=`ulimit -a`
ConsoleMessage "$var" # shows -u = 532 (which is good I think)
su - postgres -c '/usr/local/bin/pg_ctl -o "-i" -D
/Library/PostgreSQL/data -l /Library/PostgreSQL/data/logfile.log start'
}

Please. Any help would be greatly appreciated. Thanks!

---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

http://archives.postgresql.org

Nov 22 '05 #1
Share this Question
Share on Google+
2 Replies

P: n/a
Joe Lester <jo********@sweetwater.com> writes:
I'm trying to run PostgreSQL 7.4.1 on Mac OS 10.2.6. I'm running into
problems when the number of process for the postgres user reaches 100.
When that happens I get a "No More Processes" message in the terminal
shell. From then on, that user is "locked". I can't even ssh into it.


I think there is a sysctl setting that limits this; have you increased
that?

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

http://archives.postgresql.org

Nov 22 '05 #2

P: n/a
kern.maxprocperuid.... It's on OS 10.3 but not on 10.2 as far as I can
see. Anyway, I upgraded the box to 10.3.2. Then I set
kern.maxprocperuid in /etc/sysctl.conf... that seems to have done the
trick.

kern.maxprocperuid=512

Then I applied ulimit -u 512 at the shell level. It's working now.
Thanks.

On Feb 11, 2004, at 6:30 PM, Tom Lane wrote:
Joe Lester <jo********@sweetwater.com> writes:
I'm trying to run PostgreSQL 7.4.1 on Mac OS 10.2.6. I'm running into
problems when the number of process for the postgres user reaches 100.
When that happens I get a "No More Processes" message in the terminal
shell. From then on, that user is "locked". I can't even ssh into it.


I think there is a sysctl setting that limits this; have you increased
that?

regards, tom lane


---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 22 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.