By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,352 Members | 1,645 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,352 IT Pros & Developers. It's quick & easy.

problem with jdbc connection to postgesql

P: n/a
Hi All,
I am seting up my web app with a tomcat/postgresql hosting service.
From my psql client I type psql and then I am asked for my password.
This logs me into my hosted database just fine.

However, I can't log on from my webapp to the database thru jdbc like I
could when my webapp/Tomcat/postgresql were on my local machine. The
jdbc class only has a method with 3 parameters, url, user, password
parameters. The hosting server is giving me the following error message:
Stack Trace: java.sql.SQLException: FATAL 1: Password authentication failed for
user "xxxxxx" So, it looks like it is trying to connect using username xxxxxx,
not password yyyyyy.


I'm using the DriverManager.getConnection(url, user, password) method in
my connection class.

jdbc:postgresql://database.domain.org/databasename

username: xxxxxx
password: yyyyyy

It seems to be confused by the presence of the extra parameter 'user'.
I believe that the postgresql database wants just the password. How do I
give it just the url and password. There is no getConnection method on
the DriverManager classd with just url and password?

Has anyone else experienced this problem? Any ideas?
thanks,
Phil
---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 22 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Phil Campaigne wrote:
my psql client I type psql and then I am asked for my password. This
logs me into my hosted database just fine.
Ok. This is probably localhost, 127.0.0.1 and the username defaults
to your login name.
However, I can't log on from my webapp to the database thru jdbc like I

---------8<---------
>java.sql.SQLException: FATAL 1: Password authentication failed for
>user "xxxxxx"
>So, it looks like it is trying to connect using username xxxxxx,
>not password yyyyyy.


I don't think so. What happens if you try using your login name as
username?

-dirk

--
D i r k F "o r s t e r l i n g
r@zorbla.de http://r@zorbla.de/
-------------
This is robbery-mail(tm). Reply all your money immediately!
---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 22 '05 #2

P: n/a

On 03/02/2004 15:45 Phil Campaigne wrote:
Hi All,
I am seting up my web app with a tomcat/postgresql hosting service. From
my psql client I type psql and then I am asked for my password. This
logs me into my hosted database just fine.

However, I can't log on from my webapp to the database thru jdbc like I
could when my webapp/Tomcat/postgresql were on my local machine. The
jdbc class only has a method with 3 parameters, url, user, password
parameters. The hosting server is giving me the following error message:
Stack Trace:

java.sql.SQLException: FATAL 1: Password authentication failed

for >user "xxxxxx"
So, it looks like it is trying to connect using username xxxxxx,
not password yyyyyy.


I'm using the DriverManager.getConnection(url, user, password) method in
my connection class.

jdbc:postgresql://database.domain.org/databasename

username: xxxxxx
password: yyyyyy

It seems to be confused by the presence of the extra parameter 'user'. I
believe that the postgresql database wants just the password. How do I
give it just the url and password. There is no getConnection method on
the DriverManager classd with just url and password?

Has anyone else experienced this problem? Any ideas?

Well obviously you can't have a password without a user which why there is
no such method signature. Make sure that:

a) the postmaster is listening on tcp/ip port 5432 (it looks like it else
you would probably get a connect failure)

b) your user is allowed to connect to the database using tcp/ip (check
pg_hba.conf)

c) you are using the correct password for the user.
--
Paul Thomas
+------------------------------+---------------------------------------------+
| Thomas Micro Systems Limited | Software Solutions for the Smaller
Business |
| Computer Consultants |
http://www.thomas-micro-systems-ltd.co.uk |
+------------------------------+---------------------------------------------+

---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 22 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.