By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,130 Members | 1,780 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,130 IT Pros & Developers. It's quick & easy.

Where is initdb?

P: n/a
Hello List,

I have installed Postgresql 7.4 on a Suse 9.0 system using apt.
I cannot do this:

/usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data

Because there is no "/pgsql/bin/initdb" nor /pgsql/bin/ on my system.
Since apt did not create these directories how can I do it manually?
Thanks,
Jerome

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 22 '05 #1
Share this Question
Share on Google+
9 Replies


P: n/a
Mensaje citado por Jerome Lyles <su******@hawaii.rr.com>:
Hello List,

I have installed Postgresql 7.4 on a Suse 9.0 system using apt.
I cannot do this:

/usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data

Because there is no "/pgsql/bin/initdb" nor /pgsql/bin/ on my system.
Since apt did not create these directories how can I do it manually?


You don't. Normal rpm packagers put binaries in /usr/bin and not in
/usr/local/pgsql/bin.

Try this:

$ initdb -D /var/lib/pgsql/data

Or, just try to start the database with the init script:

# /etc/init.d/postgresql start

If it's like the one I have here on Fedora, it should run initdb automatically if
the Cluster hasn't been built yet.

--
select 'mmarques' || '@' || 'unl.edu.ar' AS email;
-------------------------------------------------------
Martín Marqués | Programador, DBA
Centro de Telemática | Administrador
Universidad Nacional
del Litoral
-------------------------------------------------------

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 22 '05 #2

P: n/a
Jerome Lyles wrote:
I have installed Postgresql 7.4 on a Suse 9.0 system using apt.
I cannot do this:

/usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data


Just run

/etc/init.d/postgresql start

and it will be taken care of. Read the README files in
/usr/share/doc/packages/postgresql-* to learn about how the packages
are layed out.
---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 22 '05 #3

P: n/a
although it will be taken care of, make sure that initdb sets the local
language to C or your string indexes will not be used.. Unless this has
been fixed and en_US works as as well?
On Mon, 2004-01-26 at 13:32, Peter Eisentraut wrote:
Jerome Lyles wrote:
I have installed Postgresql 7.4 on a Suse 9.0 system using apt.
I cannot do this:

/usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data


Just run

/etc/init.d/postgresql start

and it will be taken care of. Read the README files in
/usr/share/doc/packages/postgresql-* to learn about how the packages
are layed out.
---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

--
Jeremiah Jahn <je******@cs.earlham.edu>
---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 22 '05 #4

P: n/a
Mensaje citado por Jeremiah Jahn <je******@cs.earlham.edu>:
although it will be taken care of, make sure that initdb sets the local
language to C or your string indexes will not be used.. Unless this has
been fixed and en_US works as as well?


I think that if you really need very fast indexes, the first thing to do is read
the instalation manual and configure very carefully the postgres acount
(envioronment variables, etc).

--
select 'mmarques' || '@' || 'unl.edu.ar' AS email;
-------------------------------------------------------
Martín Marqués | Programador, DBA
Centro de Telemática | Administrador
Universidad Nacional
del Litoral
-------------------------------------------------------

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 22 '05 #5

P: n/a
I think it's fair to say that out of the box and RPM install should not
result in indexes not being used because the LANG is set to something
other than 'C'. I'm all for reading the manual and tuning later, but
that is something that can't be changed without a complete
dump/initdb/restore. It's just always seemed kind of misleading to me..

-jj-
On Mon, 2004-01-26 at 13:51, Martín Marqués wrote:
Mensaje citado por Jeremiah Jahn <je******@cs.earlham.edu>:
although it will be taken care of, make sure that initdb sets the local
language to C or your string indexes will not be used.. Unless this has
been fixed and en_US works as as well?


I think that if you really need very fast indexes, the first thing to do is read
the instalation manual and configure very carefully the postgres acount
(envioronment variables, etc).

--
Jeremiah Jahn <je******@cs.earlham.edu>
---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 22 '05 #6

P: n/a
Jeremiah Jahn wrote:
although it will be taken care of, make sure that initdb sets the
local language to C or your string indexes will not be used.. Unless
this has been fixed and en_US works as as well?


It has been fixed. Be sure to read the documentation about details.
---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 22 '05 #7

P: n/a
Mensaje citado por Jeremiah Jahn <je******@cs.earlham.edu>:
I think it's fair to say that out of the box and RPM install should not
result in indexes not being used because the LANG is set to something
other than 'C'. I'm all for reading the manual and tuning later, but
that is something that can't be changed without a complete
dump/initdb/restore. It's just always seemed kind of misleading to me..


The question is which should be the default? For me it's better to have
LANG=es_AR, just because I will have REAL string ordering in a query like this:

SELECT varfield FROM sometable ORDER BY varfield;

That would work great with 'C' locale if varfield didn't contain caracters like á,
é, í, ó, ú, ñ.

--
select 'mmarques' || '@' || 'unl.edu.ar' AS email;
-------------------------------------------------------
Martín Marqués | Programador, DBA
Centro de Telemática | Administrador
Universidad Nacional
del Litoral
-------------------------------------------------------

---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 22 '05 #8

P: n/a
How would I check this?
Jerome
On Monday 26 January 2004 09:43 am, Jeremiah Jahn wrote:
although it will be taken care of, make sure that initdb sets the local
language to C or your string indexes will not be used.. Unless this has
been fixed and en_US works as as well?

On Mon, 2004-01-26 at 13:32, Peter Eisentraut wrote:
Jerome Lyles wrote:
I have installed Postgresql 7.4 on a Suse 9.0 system using apt.
I cannot do this:

/usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data


Just run

/etc/init.d/postgresql start

and it will be taken care of. Read the README files in
/usr/share/doc/packages/postgresql-* to learn about how the packages
are layed out.
---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 22 '05 #9

P: n/a
On Monday 26 January 2004 06:29 pm, Uwe C. Schroeder wrote:
How about

locate initdb
It's there now. It turns out I had to also install postgresql-server.
On Monday 26 January 2004 10:37 am, Jerome Lyles wrote:
Hello List,

I have installed Postgresql 7.4 on a Suse 9.0 system using apt.
I cannot do this:

/usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data

Because there is no "/pgsql/bin/initdb" nor /pgsql/bin/ on my system.
Since apt did not create these directories how can I do it manually?
Thanks,
Jerome

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend


--
UC

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 22 '05 #10

This discussion thread is closed

Replies have been disabled for this discussion.