By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,811 Members | 1,978 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,811 IT Pros & Developers. It's quick & easy.

Slow Performance with 7.4.1

P: n/a
Hi,
I just installed pg 7.4.1 on a new system P4, 3.2Gh HT, 1GB Mem, RH9 and
discovered that some of the processes have become extremely slow. Mainly
I am talking about a SELECT COUNT(*) or VACUUM.

Before running the same database on a P4. 2Ghz 412MB mem, I got the job
done in some cases half the time.

The weird thing however is, that normal inserts seem to be much faster
on the new system and I am wondering if it is Postgres or HW related.

Does anyone has an advise ?

Thanks
Alex

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 12 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Alex <al**@meerkatsoft.com> writes:
Hi,
I just installed pg 7.4.1 on a new system P4, 3.2Gh HT, 1GB Mem, RH9
and discovered that some of the processes have become extremely
slow. Mainly I am talking about a SELECT COUNT(*) or VACUUM.

Before running the same database on a P4. 2Ghz 412MB mem, I got the
job done in some cases half the time.

The weird thing however is, that normal inserts seem to be much faster
on the new system and I am wondering if it is Postgres or HW related.

Does anyone has an advise ?


What kind of disk hardware is on the two systems?

-Doug

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 12 '05 #2

P: n/a
The old system has a 80GB, 5200rpm ATA , the new system a 120GB, 7200rpm
ATA. The new system should at least not be slower. Also, on the new
system I have a separate partition for the database.

If I run a Vacuum or a SELECT COUNT(*) on a larger table (2-6 million
records) the systems responds very slow, the screen almost freezes.

Thanks
Alex

Doug McNaught wrote:
Alex <al**@meerkatsoft.com> writes:
Hi,
I just installed pg 7.4.1 on a new system P4, 3.2Gh HT, 1GB Mem, RH9
and discovered that some of the processes have become extremely
slow. Mainly I am talking about a SELECT COUNT(*) or VACUUM.

Before running the same database on a P4. 2Ghz 412MB mem, I got the
job done in some cases half the time.

The weird thing however is, that normal inserts seem to be much faster
on the new system and I am wondering if it is Postgres or HW related.

Does anyone has an advise ?


What kind of disk hardware is on the two systems?

-Doug

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings


---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 12 '05 #3

P: n/a
Alex <al**@meerkatsoft.com> writes:
The old system has a 80GB, 5200rpm ATA , the new system a 120GB,
7200rpm ATA. The new system should at least not be slower. Also, on
the new system I have a separate partition for the database.

If I run a Vacuum or a SELECT COUNT(*) on a larger table (2-6 million
records) the systems responds very slow, the screen almost freezes.


Sounds like you may not have DMA enabled on the newer machine, or
there is some other kernel problem that slows the disk down. You
might try running Bonnie or a similar disk benchmark to make sure you
are getting the right disk performance.

-Doug

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 12 '05 #4

P: n/a
unsubscribe
---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 12 '05 #5

P: n/a
Yup, DMA is not enabled, probably that is the problem. Tried to enable
it but get an error HDIO_SET_DMA failed: Operation not permitted.

Thanks for the hint.
Alex

Doug McNaught wrote:
Alex <al**@meerkatsoft.com> writes:
The old system has a 80GB, 5200rpm ATA , the new system a 120GB,
7200rpm ATA. The new system should at least not be slower. Also, on
the new system I have a separate partition for the database.

If I run a Vacuum or a SELECT COUNT(*) on a larger table (2-6 million
records) the systems responds very slow, the screen almost freezes.


Sounds like you may not have DMA enabled on the newer machine, or
there is some other kernel problem that slows the disk down. You
might try running Bonnie or a similar disk benchmark to make sure you
are getting the right disk performance.

-Doug


---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 12 '05 #6

P: n/a
On Tue, Jan 06, 2004 at 12:50:05AM +0900, Alex wrote:
Yup, DMA is not enabled, probably that is the problem. Tried to enable
it but get an error HDIO_SET_DMA failed: Operation not permitted.

probably You have no support for Your boards chipset enabled. You
can do this ether by loading the proper module or compiling this
into Your kernel.

Hope this helps.

Greetings,
-tb
--
Thomas Beutin tb@laokoon.IN-Berlin.DE
Beam me up, Scotty. There is no intelligent live down in Redmond.

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 12 '05 #7

P: n/a
UNSUBSCRIBE

---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 12 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.