By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,809 Members | 1,999 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,809 IT Pros & Developers. It's quick & easy.

param max_connections

P: n/a
Hallo,
I am using PostgreSQL 7.4 on UltraSparc machine and I have a touble with
max_connections param.
I must set only max_connections to 8, when I set more, I got error for shared
memory.

Most connection is from J2EE application server and here is no problem, I am
using connection pooling and I have defined maximum connections for each
datasource here, but there is an old application written in php too, and here is
a problem, sometime connections runs over this param value.

Is this param familiar or I have a problem somewhere in configuration / compilation?

Server has 1 CPU UltraSparc II and 512MB RAM

Thanks for help,
Jiri

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
On Thursday 18 December 2003 08:34, ko**@chalu.cz wrote:
Hallo,
I am using PostgreSQL 7.4 on UltraSparc machine and I have a touble with
max_connections param.
I must set only max_connections to 8, when I set more, I got error for
shared memory. Is this param familiar or I have a problem somewhere in configuration /
compilation?


You should increase you shared memory settings. You probably want to do some
other tuning too if you haven't done any. There are two good articles on the
configuration file and tuning here:

http://www.varlena.com/varlena/Gener...bits/index.php

--
Richard Huxton
Archonet Ltd

---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.