By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,179 Members | 970 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,179 IT Pros & Developers. It's quick & easy.

password authentication failed for ..

P: n/a
Hi

I have the data base "test" and two users "test1" "test2". I added the following record to pg_hba.conf

local test password passwords

I then created the "passwords" file in $PGDATA using pg_pasword and added entries for the two users "test1" and "test2".

But when i tried to connect "test" using

psql test -U user1

i am always getting the message "password authentication failed for the user user1"

I enterd the password correctly.

How can i remove the problem?

thanks

---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
"Manu M P" <ma*****@maildrop.m2comsys.com> writes:
Hi

I have the data base "test" and two users "test1" "test2". I added the following record to pg_hba.conf

local test password passwords

I then created the "passwords" file in $PGDATA using pg_pasword and
added entries for the two users "test1" and "test2".


Ummm...

Passwords are stored in the 'pg_shadow' table and set using
CREATE/ALTER USER, not in a file.

I've never heard of a 'pg_password' program and it is not part of the
standard distribution.

-Doug

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 12 '05 #2

P: n/a
Doug McNaught <do**@mcnaught.org> writes:
"Manu M P" <ma*****@maildrop.m2comsys.com> writes:
I then created the "passwords" file in $PGDATA using pg_pasword and
added entries for the two users "test1" and "test2".
I've never heard of a 'pg_password' program and it is not part of the
standard distribution.


pg_passwd did exist in releases up to 7.2, but we got rid of it because
that functionality got moved into ALTER USER.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.