By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,178 Members | 971 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,178 IT Pros & Developers. It's quick & easy.

datestyle in postgresql.conf, version 7.4

P: n/a
I want to have the date in french format for my postgres 7.4 database.
reading the documentation, three ways to get it.
1. set datestyle to 'postgres,european'; for each session, it works OK
2. old style export
PGDATESTYLE='Postgres,European';/usr/local/pgsql/bin/pg_ctl -D
/home/local/BasePostgres/ -l logfile -o -i start it works OK
3. datestyle="Postgres, European" in the postgresql.conf file, but
unfortunately it does nor work

what's wrong?

--
Jean-Max Reymond email: jm*******@free.fr tel: 33 (0)6 16 94 25 11
http://jmreymond.free.fr/Etna2002
---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 12 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Jean-Max Reymond <jm*******@free.fr> writes:
3. datestyle="Postgres, European" in the postgresql.conf file, but
unfortunately it does nor work


I think you need single quotes in that file. Try

datestyle='Postgres, European'

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 12 '05 #2

P: n/a
Tom Lane wrote:
Jean-Max Reymond <jm*******@free.fr> writes:

3. datestyle="Postgres, European" in the postgresql.conf file, but
unfortunately it does nor work


I think you need single quotes in that file. Try

datestyle='Postgres, European'

sorry, but it does not work with simple or double quotes :-(
--
Jean-Max Reymond email: jm*******@free.fr tel: 33 (0)6 16 94 25 11
http://jmreymond.free.fr/Etna2002
---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 12 '05 #3

P: n/a
Jean-Max Reymond <jm*******@free.fr> writes:
Tom Lane wrote:
I think you need single quotes in that file. Try
datestyle='Postgres, European'

sorry, but it does not work with simple or double quotes :-(


Works for me (with single quotes). Did you remember to SIGHUP the
postmaster (eg with "pg_ctl reload") after editing the config file?

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 12 '05 #4

P: n/a
Tom Lane wrote:
Jean-Max Reymond <jm*******@free.fr> writes:

Tom Lane wrote:

I think you need single quotes in that file. Try
datestyle='Postgres, European'

sorry, but it does not work with simple or double quotes :-(


Works for me (with single quotes). Did you remember to SIGHUP the
postmaster (eg with "pg_ctl reload") after editing the config file?

regards, tom lane

I stop the postmaster (/usr/local/pgsql/bin/pg_ctl stop) and restart the
postmaster (/usr/local/pgsql/bin/pg_ctl -D /home/local/BasePostgres/ -l
logfile -o -i start).

I have tried with and without blanks near = (

datestyle='Postgres, European'
and
datestyle = 'Postgres, European'

but not successfull

--
Jean-Max Reymond email: jm*******@free.fr tel: 33 (0)6 16 94 25 11
http://jmreymond.free.fr/Etna2002
---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 12 '05 #5

P: n/a
Oliver Elphick wrote:
On Wed, 2003-12-10 at 23:01, Jean-Max Reymond wrote:

I stop the postmaster (/usr/local/pgsql/bin/pg_ctl stop) and restart the
postmaster (/usr/local/pgsql/bin/pg_ctl -D /home/local/BasePostgres/ -l
logfile -o -i start).

I have tried with and without blanks near = (

datestyle='Postgres, European'
and
datestyle = 'Postgres, European'

but not successfull


Are you editing the right postgresql.conf file? It should be in
$PGDATA.

Oups, you're right. I'am very confused. I have two repositories (one for
7.3 and one for 7.4) and it was not the good one!!!
thanks a lot. NOw, it works like a charm
--
Jean-Max Reymond email: jm*******@free.fr tel: 33 (0)6 16 94 25 11
http://jmreymond.free.fr/Etna2002
---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

http://archives.postgresql.org

Nov 12 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.