By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,374 Members | 2,014 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,374 IT Pros & Developers. It's quick & easy.

Turning on/off debugging

P: n/a
Hi, all.

Re: version 7.2.2

I modified the postgresql.conf file as below and got "really neat"
debugging turned on. :)
pg_ctl reload -D <dir>

Unfortunately after I was done, I wanted to turn it off again. I
commented out the lines and ran the "reload" again. This did not have
any effect. So, I thought it might just be a switch and set them to
false and reloaded. This did not change it back either. I ended up
shutting down the engine and restarting it. Of course, that worked.

Any ideas on how to do it while the engine is running?

....john

*** DETAIL ***

log_timestamp = true
log_pid = true
debug_print_query = true
---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
John Gibson <gi*@edgate.com> writes:
Unfortunately after I was done, I wanted to turn it off again. I
commented out the lines and ran the "reload" again. This did not have
any effect.


No, it wouldn't; a comment is a comment. You'd need to change the
entries to explicitly select the original setting.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 12 '05 #2

P: n/a
Tom Lane wrote:
John Gibson <gi*@edgate.com> writes:

Unfortunately after I was done, I wanted to turn it off again. I
commented out the lines and ran the "reload" again. This did not have
any effect.


No, it wouldn't; a comment is a comment. You'd need to change the
entries to explicitly select the original setting.

regards, tom lane

Thank you for responding.

Unfortunately you cut out the part where I *did* explicitly try
selecting the "false" setting.

*** from the original posting ***
So, I thought it might just be a switch and set them to false and
reloaded. This did not change it back either. I ended up shutting down
the engine and restarting it. Of course, that worked.
***

I assume from what you stated that setting the parameters from true to
false, then reloading "should" have turned off the debugging.

That is not the behavior I saw. :(

Any help would be appreciated.

....john


***** full original post below ****

Hi, all.

Re: version 7.2.2

I modified the postgresql.conf file as below and got "really neat"
debugging turned on. :)
pg_ctl reload -D <dir>

Unfortunately after I was done, I wanted to turn it off again. I
commented out the lines and ran the "reload" again. This did not have
any effect. So, I thought it might just be a switch and set them to
false and reloaded. This did not change it back either. I ended up
shutting down the engine and restarting it. Of course, that worked.

Any ideas on how to do it while the engine is running?

....john

*** DETAIL ***

log_timestamp = true
log_pid = true
debug_print_query = true
---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.