By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,373 Members | 1,984 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,373 IT Pros & Developers. It's quick & easy.

Help, Australian Time Problem

P: n/a
Is there a faq on this..cause boy it is giving me a headache.

System is FreeBSD 4.9
System date returns Tue Nov 25 16:32:36 EST 2003
Postgres Version is 7.3.4 installed from the port collection
I've set the datestyle to ISO, european
I've set australian_timezones to true
I've set TimeZone to local

I do a SELECT CURRENT_TIMESTAMP as today; or SELECT now();

and I get

2003-11-25 05:36:18.17298+00

which is 11 hours behind, how do I get it to report the correct time?

Dean


---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Dean Grubb <de**@atrium-online.com.au> writes:
I've set TimeZone to local


That will certainly not work - TimeZone needs to be set to a string that
your system will recognize as a specific time zone. (Unfortunately, a
bogus setting gets treated as "UTC" on most platforms, which in fact is
what you're seeing.)

I dunno what the standard BSD names are for the Aussie timezones; can
anyone help? On HPUX you'd use something like 'EST-10EDT' but I'm not
sure about BSD...

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 12 '05 #2

P: n/a
> On HPUX you'd use something like 'EST-10EDT' but I'm not
sure about BSD...


I did 'EST-11EDT' and now select now(); shows

2003-11-26 08:12:58.015156+11

which is correct

thanks
Dean
---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.