By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,852 Members | 2,182 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,852 IT Pros & Developers. It's quick & easy.

7.4 broke psql

P: n/a
Greetings all,

Yesterday I upgraded from 7.3 to 7.4 now psql doesn't work! I get the
following error.

psql: relocation error: psql: undefined symbol: get_progname

Any ideas out there?

Rob
---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 12 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
I hate replying to my own posts but its not broken for everyone, just
regular users. It works for postgres and root, but not for my user "robs"
robs is a database super user... weird I guess but I can live with it...

Rob

-----Original Message-----
From: pg*****************@postgresql.org
[mailto:pg*****************@postgresql.org] On Behalf Of Rob Sell
Sent: Wednesday, November 19, 2003 8:05 AM
To: pg***********@postgresql.org
Subject: [GENERAL] 7.4 broke psql

Greetings all,

Yesterday I upgraded from 7.3 to 7.4 now psql doesn't work! I get the
following error.

psql: relocation error: psql: undefined symbol: get_progname

Any ideas out there?

Rob
---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org
---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 12 '05 #2

P: n/a
Rob Sell wrote:
I hate replying to my own posts but its not broken for everyone, just
regular users. It works for postgres and root, but not for my user "robs"
robs is a database super user... weird I guess but I can live with it...


If it works for some users and not others, it must be his PATH that is
looking at the old binaries.

--
Bruce Momjian | http://candle.pha.pa.us
pg***@candle.pha.pa.us | (610) 359-1001
+ If your life is a hard drive, | 13 Roberts Road
+ Christ can be your backup. | Newtown Square, Pennsylvania 19073

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 12 '05 #3

P: n/a
Rob Sell wrote:
Greetings all,

Yesterday I upgraded from 7.3 to 7.4 now psql doesn't work! I get the
following error.

psql: relocation error: psql: undefined symbol: get_progname


Perhaps run ldconfig or remove the old binaries from your path.

--
Bruce Momjian | http://candle.pha.pa.us
pg***@candle.pha.pa.us | (610) 359-1001
+ If your life is a hard drive, | 13 Roberts Road
+ Christ can be your backup. | Newtown Square, Pennsylvania 19073

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 12 '05 #4

P: n/a
On Wed, 2003-11-19 at 09:04, Rob Sell wrote:
Greetings all,

Yesterday I upgraded from 7.3 to 7.4 now psql doesn't work! I get the
following error.

psql: relocation error: psql: undefined symbol: get_progname

Any ideas out there?


7.3 versions of psql may not work properly against 7.4 versions of the
database. Make sure you have a 7.4 version of psql.

Robert Treat
--
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL
---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 12 '05 #5

P: n/a
On Wed, 2003-11-19 at 14:04, Rob Sell wrote:
Greetings all,

Yesterday I upgraded from 7.3 to 7.4 now psql doesn't work! I get the
following error.

psql: relocation error: psql: undefined symbol: get_progname

Any ideas out there?


You are probably trying to link against an old version of libpq.so

Clean out your old installation and make sure the new psql picks up the
new shared library.

--
Oliver Elphick Ol************@lfix.co.uk
Isle of Wight, UK http://www.lfix.co.uk/oliver
GPG: 1024D/3E1D0C1C: CA12 09E0 E8D5 8870 5839 932A 614D 4C34 3E1D 0C1C
========================================
"To show forth thy lovingkindness in the morning, and
thy faithfulness every night." Psalms 92:2
---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 12 '05 #6

P: n/a
"Rob Sell" <li***@facnd.com> writes:
I hate replying to my own posts but its not broken for everyone, just
regular users. It works for postgres and root, but not for my user "robs"
robs is a database super user... weird I guess but I can live with it...


Sounds to me like a permissions problem on some shared library --- ie,
it's owned by postgres and not world-readable.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 12 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.