By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,660 Members | 1,299 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,660 IT Pros & Developers. It's quick & easy.

psql version mismatch

P: n/a
I'm trying to run the latest Postgresql on OSX 10.3, but am receiving
a version mismatch error when I try and run the database:

dyld: psql version mismatch for library:
/usr/local/lib/libreadline.4.dylib (compatibility version of user:
4.2.0 greater than library's version: 4.0.0)
Trace/BPT trap

Has anyone else run into this problem, or know of a solution?

Thanks in advance for any help,
C.
Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Simplest solution is to compile --without-readline.
However that is blow a lot of the psql functionality. If you don't use
psql then --without-readline will probably
solve it for you and you can use phpPgAdmin or pgAdmin or pgManage.

Sincerely,

Joshua Drake
Chris Fonnesbeck wrote:
I'm trying to run the latest Postgresql on OSX 10.3, but am receiving
a version mismatch error when I try and run the database:

dyld: psql version mismatch for library:
/usr/local/lib/libreadline.4.dylib (compatibility version of user:
4.2.0 greater than library's version: 4.0.0)
Trace/BPT trap

Has anyone else run into this problem, or know of a solution?

Thanks in advance for any help,
C.

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html


--
Command Prompt, Inc., home of Mammoth PostgreSQL - S/ODBC and S/JDBC
Postgresql support, programming shared hosting and dedicated hosting.
+1-503-222-2783 - jd@commandprompt.com - http://www.commandprompt.com
Editor-N-Chief - PostgreSQl.Org - http://www.postgresql.org

---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 12 '05 #2

P: n/a
sp**@fisher.forestry.uga.edu (Chris Fonnesbeck) writes:
I'm trying to run the latest Postgresql on OSX 10.3, but am receiving
a version mismatch error when I try and run the database: dyld: psql version mismatch for library:
/usr/local/lib/libreadline.4.dylib (compatibility version of user:
4.2.0 greater than library's version: 4.0.0)


This sounds like a pretty standard dynamic-linker-is-finding-wrong-
version-of-shared-library problem. I am not sufficiently familiar
with OS X to recall exactly how its linker searches for shared
libraries, but maybe that will be enough of a clue to get you
going ...

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.