467,908 Members | 1,845 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,908 developers. It's quick & easy.

Two build problems - openssl and plperl on RedHat

Greetings,

I'm trying to build 7.3.4 and I've come across two problems, one during
the configure and the other afterward.

Problem 1)

Trying to build with openssl support gives this:

../configure --with-openssl --enable-odbc --with-perl --enable-multibyte

....
checking openssl/ssl.h usability... no
checking openssl/ssl.h presence... no
checking for openssl/ssl.h... no
configure: error: header file <openssl/ssl.h> is required for OpenSSL

[root@brahma postgresql-7.3.4]# locate openssl/ssl.h
/usr/include/openssl/ssl.h

I've tried many flavors of --with-openssl=/usr/include but with no luck.

I've removed the --with-openssl, because it isn't needed immediately,
and everything configured and compiled fine.

2) I cannot figure out how to createlang plperl and plperlu. I'm getting
this message:

[postgres@brahma postgres]$ /usr/local/pgsql/bin/createlang plperlu chris
ERROR: Load of file /usr/local/pgsql/lib/plperl.so failed: libperl.so: cannot open shared object file: No such file or directory
createlang: language installation failed

The INSTALL docs state that I must have a full install of Perl (which I
do: perl-5.8.0 via RedHat's rpm) and that it Postgres won't be able to
compile if it isn't a shared object. Since Postgres compiled, can I
assume that the Perl install is ok?

My machine is a P4 running RedHat 9.0. Any info would be greatly
appreciated.

Cheers,

Chris

--
Christopher Murtagh
Enterprise Systems Administrator
ISR / Web Communications Group
McGill University
Montreal, Quebec
Canada

Tel.: (514) 398-3122
Fax: (514) 398-2017

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 12 '05 #1
  • viewed: 4963
Share:
2 Replies
Christopher Murtagh writes:
checking openssl/ssl.h usability... no
checking openssl/ssl.h presence... no
checking for openssl/ssl.h... no
configure: error: header file <openssl/ssl.h> is required for OpenSSL
Check the config.log file.
[postgres@brahma postgres]$ /usr/local/pgsql/bin/createlang plperlu chris
ERROR: Load of file /usr/local/pgsql/lib/plperl.so failed: libperl.so: cannot open shared object file: No such file or directory
createlang: language installation failed


This is an error message of the run-time loader. Perhaps you need to
tweak /etc/ld.so.conf or set LD_LIBRARY_PATH.

--
Peter Eisentraut pe*****@gmx.net
---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 12 '05 #2
Awesome! Thanks for the fast response. Both of your answers lead to me
finding the solution. For anyone in the same boat, here they are:
On Mon, 2003-11-10 at 14:00, Peter Eisentraut wrote:
Christopher Murtagh writes:
checking openssl/ssl.h usability... no
checking openssl/ssl.h presence... no
checking for openssl/ssl.h... no
configure: error: header file <openssl/ssl.h> is required for OpenSSL


Check the config.log file.


It turns out that this is a problem with RedHat and Kerberos and not
just openssl. I had the same problem with building php and needed to add
a compiler flag.

The config.log had error messages like:
/usr/include/openssl/kssl.h:134: parse error before "krb5_enctype"
[postgres@brahma postgres]$ /usr/local/pgsql/bin/createlang plperlu chris
ERROR: Load of file /usr/local/pgsql/lib/plperl.so failed: libperl.so: cannot open shared object file: No such file or directory
createlang: language installation failed


This is an error message of the run-time loader. Perhaps you need to
tweak /etc/ld.so.conf or set LD_LIBRARY_PATH.


Modified ld.so.conf to add the following two lines:

/usr/local/pgsql/lib
/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE

and then ran ldconfig.

Thanks again for the help!

Cheers,

Chris

--
Christopher Murtagh
Enterprise Systems Administrator
ISR / Web Communications Group
McGill University
Montreal, Quebec
Canada

Tel.: (514) 398-3122
Fax: (514) 398-2017

---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by Skip Montanaro | last post: by
6 posts views Thread by Gianni Mariani | last post: by
reply views Thread by Her Royal Highness Cleopatra Silvercat | last post: by
2 posts views Thread by Dan M | last post: by
2 posts views Thread by John Nagle | last post: by
reply views Thread by Darrin Thompson | last post: by
4 posts views Thread by Patrick | last post: by
7 posts views Thread by John Nagle | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.