By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,538 Members | 2,225 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,538 IT Pros & Developers. It's quick & easy.

Default user after upgrade to 7.3?

P: n/a

I just upgraded a system from RedHat 8.0 to RedHat 9.0,
which also upgrades the version of PostgreSQL.

However, I cannot run pgsql to restore the databases
because I don't know a 'default' user with permission
to run pgsql:

postmaster successfully started
LOG: database system was shut down at 2003-11-06 10:27:18 MST
LOG: checkpoint record is at 0/80193C
LOG: redo record is at 0/80193C; undo record is at 0/0; shutdown TRUE
LOG: next transaction id: 480; next oid: 16976
LOG: database system is ready
FATAL: IDENT authentication failed for user "root"
FATAL: IDENT authentication failed for user "postgres"
FATAL: IDENT authentication failed for user "swampler"

Am I missing something obvious? I couldn't find any
mention of needing to add a default user (I thought user
postgres was the default...) in the installation docs.
(And how do I do so, given that I can't run createuser
as anyone...?)

Thanks!
-Steev
--
Steve Wampler -- sw******@noao.edu
Quantum materiae materietur marmota monax si marmota
monax materiam possit materiari?

---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Steve Wampler writes:
FATAL: IDENT authentication failed for user "root"
FATAL: IDENT authentication failed for user "postgres"
FATAL: IDENT authentication failed for user "swampler"


Check the file pg_hba.conf (somewhere under /var/lib/pgsql probably) to
see what kind of authentication it requires from you. If you don't know
how to work with the authentication that has been set up by the package,
change everything that reads "ident" to "trust" and restart the database
server. That is not safe, but it will allow you to get in.

--
Peter Eisentraut pe*****@gmx.net
---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.