469,271 Members | 1,727 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,271 developers. It's quick & easy.

SET AUTOCOMMIT OFF

Hi,

I have got an error with PostgreSQL-7.4Beta4 :
ERROR SET AUTOCOMMIT TO OFF is no longer supported

I used these option to load huge Database as i can save time with it. Is
there an other option in PG 7.4 to do the same ?

Regards
Thierry Missimilly
---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

http://archives.postgresql.org

Nov 12 '05 #1
3 9901
Thierry Missimilly <TH****************@BULL.NET> writes:
I have got an error with PostgreSQL-7.4Beta4 :
ERROR SET AUTOCOMMIT TO OFF is no longer supported
I used these option to load huge Database as i can save time with it. Is
there an other option in PG 7.4 to do the same ?


psql has a \set command for it. See the release notes.

BTW, if you are going to load any huge databases I'd suggest updating to
beta5 or RC1 first. We forced an initdb between beta4 and beta5 IIRC.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 12 '05 #2
Do you mean that, this doesn't work any more ??

from jdbc
connextion.setAutoCommit(false)
Tom Lane wrote:
Thierry Missimilly <TH****************@BULL.NET> writes:
I have got an error with PostgreSQL-7.4Beta4 :
ERROR SET AUTOCOMMIT TO OFF is no longer supported
I used these option to load huge Database as i can save time with it. Is
there an other option in PG 7.4 to do the same ?


psql has a \set command for it. See the release notes.

BTW, if you are going to load any huge databases I'd suggest updating to
beta5 or RC1 first. We forced an initdb between beta4 and beta5 IIRC.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 12 '05 #3
Kathy Zhu wrote:
Do you mean that, this doesn't work any more ??

from jdbc
connextion.setAutoCommit(false)


jdbc still works. We have pushed the autocommit out to the clients like
psql and jdbc, rather than having the backend do it.

--
Bruce Momjian | http://candle.pha.pa.us
pg***@candle.pha.pa.us | (610) 359-1001
+ If your life is a hard drive, | 13 Roberts Road
+ Christ can be your backup. | Newtown Square, Pennsylvania 19073

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 12 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Marcus | last post: by
reply views Thread by jy2003 | last post: by
reply views Thread by Scott Mills | last post: by
1 post views Thread by Lynn.Tilby | last post: by
4 posts views Thread by Christian Traber | last post: by
1 post views Thread by Carmen Gloria Sepulveda Dedes | last post: by
reply views Thread by Carmen Gloria Sepulveda Dedes | last post: by
1 post views Thread by Matt Van Mater | last post: by
33 posts views Thread by John Sidney-Woollett | last post: by
2 posts views Thread by Jia Lu | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.