By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,660 Members | 1,299 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,660 IT Pros & Developers. It's quick & easy.

./configure error - readline library not found

P: n/a
Howdy.

I looked around for an answer to this, but I was unable to find one that
seemed to match my situation. (Incidentally, now I cannot get
archives.postgresql.org to respond to my search query...)

I'm trying to build 7.3.4 on Libranet2.8.1 (debian). I've built
PostgreSQL many times in the past on stock RedHat distros and had no
problem.

When running ./configure, I keep getting stuck when it checks for readline.

checking for readline... no
configure: error: readline library not found
If you have readline already installed, see config.log ...

I've looked in config.log and I don't really get any more explanation
about why it couldn't find the library.

I've tried different --with-libs= paths and had no luck.

I have libreadline4.3-4 installed, and I think the relevant library file
is /lib/libreadline.so.4

Any suggestions?

Thanks much.

Michael Teter


---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 12 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Michael Teter <mt****@1scom.net> writes:
Howdy.

I looked around for an answer to this, but I was unable to find one
that seemed to match my situation. (Incidentally, now I cannot get
archives.postgresql.org to respond to my search query...)

I'm trying to build 7.3.4 on Libranet2.8.1 (debian). I've built
PostgreSQL many times in the past on stock RedHat distros and had no
problem.
You probably need to install the -devel package for readline. I have libreadline4.3-4 installed, and I think the relevant library
file is /lib/libreadline.so.4


This is the runtime part of the library, but you need the headers to
compile, which are in the -devel package.

-Doug

---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 12 '05 #2

P: n/a
Thanks much, that was my problem.

For the record, the debian package name (which took me a while to
determine) is:

libreadline4-dev

Thanks again.

MT

Doug McNaught wrote:
Michael Teter <mt****@1scom.net> writes:

Howdy.

I looked around for an answer to this, but I was unable to find one
that seemed to match my situation. (Incidentally, now I cannot get
archives.postgresql.org to respond to my search query...)

I'm trying to build 7.3.4 on Libranet2.8.1 (debian). I've built
PostgreSQL many times in the past on stock RedHat distros and had no
problem.

You probably need to install the -devel package for readline.
I have libreadline4.3-4 installed, and I think the relevant library
file is /lib/libreadline.so.4

This is the runtime part of the library, but you need the headers to
compile, which are in the -devel package.

-Doug

---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org


---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 12 '05 #3

P: n/a
On Fri, Oct 24, 2003 at 03:42:01PM -0400, Doug McNaught wrote:
Michael Teter <mt****@1scom.net> writes:
I'm trying to build 7.3.4 on Libranet2.8.1 (debian). I've built
PostgreSQL many times in the past on stock RedHat distros and had no
problem.


You probably need to install the -devel package for readline.


I think you also need ncurses-devel or termcap-devel, or some other
apparently unrelated package.

--
Alvaro Herrera (<alvherre[a]dcc.uchile.cl>)
"I call it GNU/Linux. Except the GNU/ is silent." (Ben Reiter)

---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 12 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.