By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,776 Members | 1,777 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,776 IT Pros & Developers. It's quick & easy.

Pgsql 7.3.3 on redhat 7.2

P: n/a
> I can't get a rest for a min guys.

I go away for the weekend and my server is getting this error.

Fatal error: Call to undefined function: pg_connect() in
/var/www/html/crohns/phpBB2/db/postgres7.php on line 79


Your PHP doesn't have support for PostgreSQL.

Look at phpinfo();

--->
From the backup to the current php.ini file... this is what was changed...
Looks like an autoupdate on php happened.

This was turned off in the current php.ini
;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;

; Whether to allow HTTP file uploads.
file_uploads = Off
the backup had this tuned on

?

this cause it?

-Dan

---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 12 '05 #1
Share this Question
Share on Google+
11 Replies


P: n/a
El Lun 20 Oct 2003 11:08, Daniel E. Fisher escribió:
From the backup to the current php.ini file... this is what was changed...
Looks like an autoupdate on php happened.

This was turned off in the current php.ini
;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;

; Whether to allow HTTP file uploads.
file_uploads = Off
This has nothing to do.

the backup had this tuned on


echo "<?php phpinfo() ?>" | php | lynx

Aparently you are not uning the PostgreSQL that came with your RH 7.2, and
(somebody correct me) I think the libpq client changed, so recompilation is
needed.

By the way, you should give better information about the server. Tell us about
what version of PHP you are using. Did it come with RH? How about PgSQL?

--
11:25:01 up 17 days, 20:57, 3 users, load average: 0.29, 0.73, 0.96
-----------------------------------------------------------------
Martín Marqués | mm******@unl.edu.ar
Programador, Administrador, DBA | Centro de Telematica
Universidad Nacional
del Litoral
-----------------------------------------------------------------
---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 12 '05 #2

P: n/a
On Mon, Oct 20, 2003 at 10:08:08AM -0400, Daniel E. Fisher wrote:
From the backup to the current php.ini file... this is what was changed...

Looks like an autoupdate on php happened.

This was turned off in the current php.ini


Huh, it doesn't sound like it could affect the Postgres support.
However what could have happenned (I've seen it) is that there was some
previous change that didn't take effect because the server wasn't
restarted. So if this is your first httpd restart in some time, you
better start investigating...

If you are having updates applied behind your back, maybe the libpq
shared library changed version (libpq.so.2 -> libpq.so.3), and now PHP
is failing to load it. Read your server logs ...

--
Alvaro Herrera (<alvherre[a]dcc.uchile.cl>)
"You knock on that door or the sun will be shining on places inside you
that the sun doesn't usually shine" (en Death: "The High Cost of Living")

---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 12 '05 #3

P: n/a
I have in the /var/lib/
libpq.so.2
libpq.so.2.0
libpq.so.2.1
libpq.so

also found
/usr/local/pgsql/lib/libpq.so.3
/usr/local/pgsql/lib/libpq.so.3.0
/usr/local/pgsql/lib/libpq.so

After reading all my server logs:

No error messages or nothing. Weird..

May have something to do with reading wrong libpq Alvaro?

-Dan
-Always appreciative of help

-----Original Message-----
From: Alvaro Herrera [mailto:al******@dcc.uchile.cl]
Sent: Monday, October 20, 2003 11:28 AM
To: Daniel E. Fisher
Cc: PGSQL List
Subject: Re: [GENERAL] Pgsql 7.3.3 on redhat 7.2
On Mon, Oct 20, 2003 at 10:08:08AM -0400, Daniel E. Fisher wrote:
From the backup to the current php.ini file... this is what was
changed... Looks like an autoupdate on php happened.

This was turned off in the current php.ini


Huh, it doesn't sound like it could affect the Postgres support.
However what could have happenned (I've seen it) is that there was some
previous change that didn't take effect because the server wasn't
restarted. So if this is your first httpd restart in some time, you
better start investigating...

If you are having updates applied behind your back, maybe the libpq
shared library changed version (libpq.so.2 -> libpq.so.3), and now PHP
is failing to load it. Read your server logs ...

--
Alvaro Herrera (<alvherre[a]dcc.uchile.cl>)
"You knock on that door or the sun will be shining on places inside you
that the sun doesn't usually shine" (en Death: "The High Cost of Living")
---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 12 '05 #4

P: n/a
On Mon, Oct 20, 2003 at 01:03:23PM -0400, Daniel E. Fisher wrote:
After reading all my server logs:

No error messages or nothing. Weird..
Including Apache's /var/log/httpd/access_log and
/var/log/httpd/error_log during restart?
(or wherever you may have moved them)
May have something to do with reading wrong libpq Alvaro?


Maybe ... check out what ldd path-to-pgsql.so says (PHP's support
library)

--
Alvaro Herrera (<alvherre[a]dcc.uchile.cl>)
"Nadie esta tan esclavizado como el que se cree libre no siendolo" (Goethe)

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 12 '05 #5

P: n/a
Already upgrading..see how it goes.

-Dan

-----Original Message-----
From: pg*****************@postgresql.org
[mailto:pg*****************@postgresql.org]On Behalf Of Alvaro Herrera
Sent: Monday, October 20, 2003 3:03 PM
To: Daniel E. Fisher
Cc: PGSQL List
Subject: Re: [GENERAL] Pgsql 7.3.3 on redhat 7.2
On Mon, Oct 20, 2003 at 01:03:23PM -0400, Daniel E. Fisher wrote:
After reading all my server logs:

No error messages or nothing. Weird..
Including Apache's /var/log/httpd/access_log and
/var/log/httpd/error_log during restart?
(or wherever you may have moved them)
May have something to do with reading wrong libpq Alvaro?


Maybe ... check out what ldd path-to-pgsql.so says (PHP's support
library)

--
Alvaro Herrera (<alvherre[a]dcc.uchile.cl>)
"Nadie esta tan esclavizado como el que se cree libre no siendolo" (Goethe)

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 12 '05 #6

P: n/a
Ok...ran into problems backing database up.

trying to run pg_dumpall > backup102003

gives me

Database version 7.3.3 compiled by gcc 2.96

Archiver DB ver 7.1.3
Aborting cause of version mismatch.

use ignore if ok?

Now it does have 7.3.3 on it but that is the old version of 7.1.3
before the upgrade. I really want to backup my data before I do this..
but is it safe to ignore...

I did copy /usr/local/pgsql to another directory just incase...
is this good enough?

-Dan

-----Original Message-----
From: pg*****************@postgresql.org
[mailto:pg*****************@postgresql.org]On Behalf Of Alvaro Herrera
Sent: Monday, October 20, 2003 3:03 PM
To: Daniel E. Fisher
Cc: PGSQL List
Subject: Re: [GENERAL] Pgsql 7.3.3 on redhat 7.2
On Mon, Oct 20, 2003 at 01:03:23PM -0400, Daniel E. Fisher wrote:
After reading all my server logs:

No error messages or nothing. Weird..
Including Apache's /var/log/httpd/access_log and
/var/log/httpd/error_log during restart?
(or wherever you may have moved them)
May have something to do with reading wrong libpq Alvaro?


Maybe ... check out what ldd path-to-pgsql.so says (PHP's support
library)

--
Alvaro Herrera (<alvherre[a]dcc.uchile.cl>)
"Nadie esta tan esclavizado como el que se cree libre no siendolo" (Goethe)

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 12 '05 #7

P: n/a
On Mon, Oct 20, 2003 at 03:23:39PM -0400, Daniel E. Fisher wrote:
Ok...ran into problems backing database up.

trying to run pg_dumpall > backup102003

gives me

Database version 7.3.3 compiled by gcc 2.96
Archiver DB ver 7.1.3
Aborting cause of version mismatch.


Huh... apparently you are running pg_dumpall from a very old version.
You should look around your system for a more recent version ... don't
trust you PATH on this! Use pg_dumpall --version and check the version
number.

BTW, you should be using 7.3.4 anyway. I just had somebody with a
postmaster that refused to start because of a bug in 7.3.3 on another
list.

--
Alvaro Herrera (<alvherre[a]dcc.uchile.cl>)
Licensee shall have no right to use the Licensed Software
for productive or commercial use. (Licencia de StarOffice 6.0 beta)

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 12 '05 #8

P: n/a
El Lun 20 Oct 2003 14:03, Daniel E. Fisher escribió:
I have in the /var/lib/
libpq.so.2
libpq.so.2.0
libpq.so.2.1
libpq.so
These look like the ones that came with the postgresql-libs rpm from RH.
also found
/usr/local/pgsql/lib/libpq.so.3
/usr/local/pgsql/lib/libpq.so.3.0
/usr/local/pgsql/lib/libpq.so
These look like newly install from source libraries.
If this is true, you should (or the sys admin) "rpm -e postgresql-libs".
And add "/usr/local/pgsql/lib" to LD_LIBRARY_PATH or add in to
/etc/ld.so.conf.
After reading all my server logs:

No error messages or nothing. Weird..


I think you're gonna have to recompile PHP, or go back to the version that
came with RH 7.2 (I would recommend moving to RH 9 which comes with a much
newer version of PostgreSQL and PHP).

--
El mejor sistema operativo es aquel que te da de comer.
Cuida tu dieta.
-----------------------------------------------------------------
Martin Marques | mm******@unl.edu.ar
Programador, Administrador | Centro de Telematica
Universidad Nacional
del Litoral
-----------------------------------------------------------------
---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 12 '05 #9

P: n/a
I found the current version and ran pg_dumpall > backup

it dumped everything correctly....

I am now preforming the upgrade...to 7.3.4

Thanks for the help everyone...we will get this yet.

-Dan

-----Original Message-----
From: pg*****************@postgresql.org
[mailto:pg*****************@postgresql.org]On Behalf Of Alvaro Herrera
Sent: Monday, October 20, 2003 4:19 PM
To: Daniel E. Fisher
Cc: PGSQL List
Subject: Re: [GENERAL] Pgsql 7.3.3 on redhat 7.2
On Mon, Oct 20, 2003 at 03:23:39PM -0400, Daniel E. Fisher wrote:
Ok...ran into problems backing database up.

trying to run pg_dumpall > backup102003

gives me

Database version 7.3.3 compiled by gcc 2.96
Archiver DB ver 7.1.3
Aborting cause of version mismatch.


Huh... apparently you are running pg_dumpall from a very old version.
You should look around your system for a more recent version ... don't
trust you PATH on this! Use pg_dumpall --version and check the version
number.

BTW, you should be using 7.3.4 anyway. I just had somebody with a
postmaster that refused to start because of a bug in 7.3.3 on another
list.

--
Alvaro Herrera (<alvherre[a]dcc.uchile.cl>)
Licensee shall have no right to use the Licensed Software
for productive or commercial use. (Licencia de StarOffice 6.0 beta)

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 12 '05 #10

P: n/a
hi,
it seems you use the /usr/bin/pg_dumpall featured by the redhat default
install

verify this with "which pg_dumpall"
(rpm -ql postgresql to see all the files of this package)

you upgraded from sources didn't you ?

your fresh new install has the default prefix /usr/local (redhat uses /usr)

2 ways : recompile/install with ./configure --prefix=/usr ...
or remove completely the redhat postgresql package (rpm -e postgresql)

By the way, UPGRADE YOU GCC!

2.96's is a redhat experimental buggy compiler (it should never have
been released)

I don't mean installing gcc-3.x but don't stay with 2.96 (2.95.x is good)
Daniel E. Fisher wrote:
Ok...ran into problems backing database up.

trying to run pg_dumpall > backup102003

gives me

Database version 7.3.3 compiled by gcc 2.96

Archiver DB ver 7.1.3
Aborting cause of version mismatch.

use ignore if ok?

Now it does have 7.3.3 on it but that is the old version of 7.1.3
before the upgrade. I really want to backup my data before I do this..
but is it safe to ignore...

I did copy /usr/local/pgsql to another directory just incase...
is this good enough?

-Dan

-----Original Message-----
From: pg*****************@postgresql.org
[mailto:pg*****************@postgresql.org]On Behalf Of Alvaro Herrera
Sent: Monday, October 20, 2003 3:03 PM
To: Daniel E. Fisher
Cc: PGSQL List
Subject: Re: [GENERAL] Pgsql 7.3.3 on redhat 7.2
On Mon, Oct 20, 2003 at 01:03:23PM -0400, Daniel E. Fisher wrote:
After reading all my server logs:

No error messages or nothing. Weird..


Including Apache's /var/log/httpd/access_log and
/var/log/httpd/error_log during restart?
(or wherever you may have moved them)
May have something to do with reading wrong libpq Alvaro?


Maybe ... check out what ldd path-to-pgsql.so says (PHP's support
library)

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 12 '05 #11

P: n/a

On 22/10/2003 14:36 frbn wrote:
hi,
it seems you use the /usr/bin/pg_dumpall featured by the redhat default
install

verify this with "which pg_dumpall"
(rpm -ql postgresql to see all the files of this package)

you upgraded from sources didn't you ?

your fresh new install has the default prefix /usr/local (redhat uses
/usr)

2 ways : recompile/install with ./configure --prefix=/usr ...
or remove completely the redhat postgresql package (rpm -e postgresql)


I've found the easiest way to over-write a RPM installed version with one
one compiled from source is to use pg_config --configure to get all the
original options which the RMP version was built with. I then supply these
options to the configure script. This way, I know that the new version
will over-write the old version.

HTH

--
Paul Thomas
+------------------------------+---------------------------------------------+
| Thomas Micro Systems Limited | Software Solutions for the Smaller
Business |
| Computer Consultants |
http://www.thomas-micro-systems-ltd.co.uk |
+------------------------------+---------------------------------------------+

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 12 '05 #12

This discussion thread is closed

Replies have been disabled for this discussion.