By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,773 Members | 1,724 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,773 IT Pros & Developers. It's quick & easy.

Upgrading to 7.4beta

P: n/a
Greetings All,

I compiled pg from source last week as pg 7.3.4 which worked sweet. Then Idecided there was some functionality in 7.4beta that I just needed to lookat :-)

So I:
*stopped pg
*downloaded the source
*deleted data dir
*configured, gmake, gmake install
*init db
*setup db

awesome? Accept when I go slection version() pg tells me 7.3.4 !!!!

I realise this is rather newbie, but suggestions are greatfully accepted :-)
Z.

Nov 12 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Sorted :-)

Z.
----- Original Message -----
From: Zitan Broth
To: PostgreSQL general list
Sent: Monday, October 13, 2003 4:37 PM
Subject: [GENERAL] Upgrading to 7.4beta
Greetings All,

I compiled pg from source last week as pg 7.3.4 which worked sweet. ThenI decided there was some functionality in 7.4beta that I just needed to look at :-)

So I:
*stopped pg
*downloaded the source
*deleted data dir
*configured, gmake, gmake install
*init db
*setup db

awesome? Accept when I go slection version() pg tells me 7.3.4 !!!!

I realise this is rather newbie, but suggestions are greatfully accepted :-)
Z.

Nov 12 '05 #2

P: n/a
Zitan Broth wrote:
Sorted :-)


Curiously, how?

Shridhar

---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 12 '05 #3

P: n/a
Hi,
I just installed 7.3.4 on a solaris machine (solaris 8) but can't get
postmaster to start.

It always terminates with the message
ld.so.1: /..../postgres: fata: libreadline.so.4: open failed: No such
file or directory

1: LD_LIBRARY_PATH is set at installation time and when starting the
postmaster
2: the libreadline.so.4 is installed (solaris package)

I did not have a problem on other solaris machines but something seems
to be missing. Is there a way to link the libreadline ?

Alex


---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 12 '05 #4

P: n/a
As far as i Know libreadline is a library file that comes with gcc. (
But don't quote me on that)
On my solaris 8 box it is insalled in /opt/sfw/lib. But there is a link
from libreadline.so set to libreadline.so.4
you could try making this link and setting the LD_LIBRARY_PATH to the
directory with the link.
I got the exact error you did before. It's just a library path error.
Postgres can't find the correct library to load.

David

Alex wrote:
Hi,
I just installed 7.3.4 on a solaris machine (solaris 8) but can't get
postmaster to start.

It always terminates with the message
ld.so.1: /..../postgres: fata: libreadline.so.4: open failed: No such
file or directory

1: LD_LIBRARY_PATH is set at installation time and when starting the
postmaster
2: the libreadline.so.4 is installed (solaris package)

I did not have a problem on other solaris machines but something seems
to be missing. Is there a way to link the libreadline ?

Alex


---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings


---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 12 '05 #5

P: n/a
The LD_LIBRARY_PATH actually points to the library, I am even able to
execute the initdb but the postmaster always fails

Alex

David McLoughlin wrote:
As far as i Know libreadline is a library file that comes with gcc. (
But don't quote me on that)
On my solaris 8 box it is insalled in /opt/sfw/lib. But there is a
link from libreadline.so set to libreadline.so.4
you could try making this link and setting the LD_LIBRARY_PATH to the
directory with the link.
I got the exact error you did before. It's just a library path error.
Postgres can't find the correct library to load.

David

Alex wrote:
Hi,
I just installed 7.3.4 on a solaris machine (solaris 8) but can't get
postmaster to start.

It always terminates with the message
ld.so.1: /..../postgres: fata: libreadline.so.4: open failed: No such
file or directory

1: LD_LIBRARY_PATH is set at installation time and when starting the
postmaster
2: the libreadline.so.4 is installed (solaris package)

I did not have a problem on other solaris machines but something
seems to be missing. Is there a way to link the libreadline ?

Alex


---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings


---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if
your
joining column's datatypes do not match


---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 12 '05 #6

P: n/a
Alex <al**@meerkatsoft.com> writes:
The LD_LIBRARY_PATH actually points to the library, I am even able to
execute the initdb but the postmaster always fails


In that case, almost certainly, the environment you are starting the
postmaster in is different from the one you ran initdb in (no
LD_LIBRARY_PATH setting, probably). Better check where LD_LIBRARY_PATH
is set and how that setting will propagate to the postmaster.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 12 '05 #7

P: n/a
El Lun 13 Oct 2003 11:38, Tom Lane escribió:
Alex <al**@meerkatsoft.com> writes:
The LD_LIBRARY_PATH actually points to the library, I am even able to
execute the initdb but the postmaster always fails


In that case, almost certainly, the environment you are starting the
postmaster in is different from the one you ran initdb in (no
LD_LIBRARY_PATH setting, probably). Better check where LD_LIBRARY_PATH
is set and how that setting will propagate to the postmaster.


Listen carfully to what Tom says, cuase he helped me with this same problem in
the past! :-)

What I did was put in the /etc/init.d/postgresql file, at the line that starts
the postmaster (executing the postamaster directly or running pg_ctl) the
longer LD_LIBRARY_PATH.

Something like this:

echo -n "Starting postgresql service: "
su - postgres -c "export
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib; /dbs/postgres/bin/pg_ctl -o
\"-o -e\" -D /dbs/postgres/data/ start >& /dev/null"

Sorry for the lines that got cut. :-(

--
Porqué usar una base de datos relacional cualquiera,
si podés usar PostgreSQL?
-----------------------------------------------------------------
Martín Marqués | mm******@unl.edu.ar
Programador, Administrador, DBA | Centro de Telemática
Universidad Nacional
del Litoral
-----------------------------------------------------------------
---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 12 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.