By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,778 Members | 1,793 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,778 IT Pros & Developers. It's quick & easy.

simple remote user access question - pg_hda.conf

P: n/a
tj
I can't seem to get the file configured correctly.
This works:
montgomery@spudbox1: psql mydb

This does NOT work:
montgomery@spudbox1:> psql -h 10.10.10.70 mydb
psql: FATAL 1: No pg_hba.conf entry for host 10.10.10.70, user montgomery,
database mydb

This does NOT work either:
montgomery@spudbox1:> psql -h 10.10.10.70 mydb -U montgomery
psql: FATAL 1: No pg_hba.conf entry for host 10.10.10.70, user montgomery,
database mydb

Ok, here's my setup:
host: "spudbox1"; 10.10.10.70 (database server, web server)
database: mydb (7.2.2); postmaster running with "-i".
user: montgomery (user was created on system, and also in db)

pg_hda.conf:
# TYPE DATABASE IP_ADDRESS MASK AUTH_TYPE
local all trust
host all 127.0.0.1 255.255.255.255 trust
host mydb 10.10.10.* 255.255.255.0 trust
Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
tj
I just discovered that SuSE provides the sample pg_hba.conf in
/usr/share/pgsql

but the real pg_hba.conf file is located in
/var/lib/pgsql/data

Fixed!

Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.