471,316 Members | 1,261 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,316 software developers and data experts.

problems retrieving images in 7.3.4

Greetings,

I am new to this list. I have a problem with BLOBS using PostgreSQL7.3.4.

I used the lo_export utility to insert an image into a trial database. I have
not been able to use the lo_export utility to retrieve it. I have done this
successfully before using PostgreSQL7.2.

Assuming I have a table name TABLE with columns named TITLE and IMAGE. I (
working as postgres ) issued the following select statement :

SELECT lo_export(table.image('/tmp/outimage.jpg')
from TABLE
where TITLE ='First Picture';

I get in response 'cant open unix file system "/tmp/outimage.jpg" no such
file or directory. The problem seems to be the filename. So I tried
different filenames such as image2.jpg, etc with the same result.

I looked at the /tmp directory and I did not see any jpegs. I also looked
at the postgres/data directory to see if there is a directory labelled /tmp.
I was unsuccessful. I am using a PC running SuSE8.2.

Some help will be appreciated.

Yours sincerely
Sibu

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 12 '05 #1
0 1111

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Scott | last post: by
3 posts views Thread by John Tacke | last post: by
reply views Thread by Dirk Vervecken | last post: by
7 posts views Thread by Sirplaya | last post: by
2 posts views Thread by Bjorn Sagbakken | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.